summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-08-18 22:42:21 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-08-18 22:42:21 +0000
commitd6513426029967fb1c36d9097faed868979754ef (patch)
tree00d75f95a4b12ca8a38f296c18aab9a42e100a4c /app-editors/gobby/gobby-0.4.5.ebuild
parentInitial Commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. (diff)
downloadhistorical-d6513426029967fb1c36d9097faed868979754ef.tar.gz
historical-d6513426029967fb1c36d9097faed868979754ef.tar.bz2
historical-d6513426029967fb1c36d9097faed868979754ef.zip
Version bump (bug #171089), fixes bugs #132752, #180286. Dropped old version.
Package-Manager: portage-2.1.3.6
Diffstat (limited to 'app-editors/gobby/gobby-0.4.5.ebuild')
-rw-r--r--app-editors/gobby/gobby-0.4.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/gobby/gobby-0.4.5.ebuild b/app-editors/gobby/gobby-0.4.5.ebuild
new file mode 100644
index 000000000000..dc42fda9915e
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: gobby-0.4.5.ebuild,v 1.1 2007/08/18 22:42:21 dev-zero Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi gnome"
+
+DEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-cpp/gtkmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=net-libs/obby-0.4.4
+ >=dev-cpp/libxmlpp-2.6
+ >=x11-libs/gtksourceview-1.2.0
+ gnome? ( gnome-base/gnome-vfs )"
+RDEPEND="${DEPEND}"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-libs/obby avahi ; then
+ eerror "Please reinstall net-libs/obby with the avahi USE-flag enabled"
+ eerror "for zeroconf/DNS-SD support or disable it for this package."
+ die "Missing 'avahi' USE-flag for net-libs/obby"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-gtksourceview \
+ $(use_with gnome) \
+ || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ domenu contrib/gobby.desktop
+}