summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-13 18:31:45 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-13 18:31:45 +0000
commit0e93b78e9bf8b7763c38b4054ba7ed3d3bfd1dae (patch)
tree651cfa0ab870bb37086cdaa3d5647e3d68e712e6 /app-editors
parentstable bump (diff)
downloadhistorical-0e93b78e9bf8b7763c38b4054ba7ed3d3bfd1dae.tar.gz
historical-0e93b78e9bf8b7763c38b4054ba7ed3d3bfd1dae.tar.bz2
historical-0e93b78e9bf8b7763c38b4054ba7ed3d3bfd1dae.zip
Version bump closes #74254
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog7
-rw-r--r--app-editors/scite/files/digest-scite-1.6.21
-rw-r--r--app-editors/scite/scite-1.6.2.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index f61194e37f44..d893edac6c59 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.30 2004/10/27 05:00:36 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.31 2004/12/13 18:31:45 pythonhead Exp $
+
+*scite-1.6.2 (13 Dec 2004)
+
+ 13 Dec 2004; Rob Cakebread <pythonhead@gentoo.org> +scite-1.6.2.ebuild:
+ Version bump closes #74254
26 Oct 2004; Rob Cakebread <pythonhead@gentoo.org> -scite-1.4.9.ebuild,
scite-1.5.6.ebuild, scite-1.5.7.ebuild, scite-1.5.8.ebuild,
diff --git a/app-editors/scite/files/digest-scite-1.6.2 b/app-editors/scite/files/digest-scite-1.6.2
new file mode 100644
index 000000000000..edd7f730c214
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.6.2
@@ -0,0 +1 @@
+MD5 4d34c8b669f0a8e0ae862a8e56fd8d01 scite162.tgz 1140114
diff --git a/app-editors/scite/scite-1.6.2.ebuild b/app-editors/scite/scite-1.6.2.ebuild
new file mode 100644
index 000000000000..badd3cac2221
--- /dev/null
+++ b/app-editors/scite/scite-1.6.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.6.2.ebuild,v 1.1 2004/12/13 18:31:45 pythonhead Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="gtk2 lua"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ || die "error patching makefile"
+
+}
+
+src_compile() {
+ local makeopts
+ use gtk2 || makeopts="GTK1=1"
+ #use debug && makeopts="${makeopts} DEBUG=1"
+
+ make -C ../../scintilla/gtk ${makeopts} || die "prep make failed"
+ emake ${makeopts} || die "make failed"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /usr/share
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}