summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-04-11 12:16:30 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-04-11 12:16:30 +0000
commit46abc5ef432add7729ec6a206467bc3d3bf14960 (patch)
treeccc3ae876bf7e95d47583579af85f547959ff9da /app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
parentMark as stable on all archs and remove old versions (diff)
downloadhistorical-46abc5ef432add7729ec6a206467bc3d3bf14960.tar.gz
historical-46abc5ef432add7729ec6a206467bc3d3bf14960.tar.bz2
historical-46abc5ef432add7729ec6a206467bc3d3bf14960.zip
Initial import
Diffstat (limited to 'app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild')
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
new file mode 100644
index 000000000000..957bc20f2134
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.07.ebuild,v 1.1 2004/04/11 12:16:30 mattam Exp $
+
+inherit elisp
+
+IUSE=""
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc
+"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${MY_P}/emacs"
+
+src_compile() {
+ COMPILECMD='(progn
+ (setq load-path (cons "." load-path))
+ (byte-compile-file "caml-xemacs.el")
+ (byte-compile-file "caml-emacs.el")
+ (byte-compile-file "caml.el")
+ (byte-compile-file "inf-caml.el")
+ (byte-compile-file "caml-help.el")
+ (byte-compile-file "camldebug.el"))'
+ emacs -batch -eval "${COMPILECMD}"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50ocaml-mode-gentoo.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}