summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-07-06 19:41:28 +0000
committerMike Auty <ikelos@gentoo.org>2008-07-06 19:41:28 +0000
commit345dd372f5a6d32f64ec77601000f1d446f9972f (patch)
treefb5d2669d7cde11828e3480983eb16b10702a062 /app-emulation/open-vm-tools/files
parentStable on sparc, bug #214731 (diff)
downloadhistorical-345dd372f5a6d32f64ec77601000f1d446f9972f.tar.gz
historical-345dd372f5a6d32f64ec77601000f1d446f9972f.tar.bz2
historical-345dd372f5a6d32f64ec77601000f1d446f9972f.zip
Version bump.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686
Diffstat (limited to 'app-emulation/open-vm-tools/files')
-rw-r--r--app-emulation/open-vm-tools/files/default-scripts.patch139
-rw-r--r--app-emulation/open-vm-tools/files/disable-toolbox.patch53
2 files changed, 139 insertions, 53 deletions
diff --git a/app-emulation/open-vm-tools/files/default-scripts.patch b/app-emulation/open-vm-tools/files/default-scripts.patch
new file mode 100644
index 000000000000..2136dad71d90
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/default-scripts.patch
@@ -0,0 +1,139 @@
+diff --git a/scripts/linux/resume-vm-default b/scripts/linux/resume-vm-default
+index cebbba0..dbd38a6 100644
+--- a/scripts/linux/resume-vm-default
++++ b/scripts/linux/resume-vm-default
+@@ -25,41 +25,10 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ rescue_NIC() {
+ niclist="/var/run/vmware-active-nics"
+
+- ifup_path=`which ifup 2>/dev/null`;
++ ifup_path="/etc/init.d/net.";
+ if [ $? -ne 0 ]; then
+ return 1;
+ fi
+@@ -76,7 +45,7 @@ rescue_NIC() {
+ else
+ echo `date` "[rescue_nic] activating $nic ..."
+
+- $ifup_path $nic
++ $ifup_path$nic restart
+ fi
+ done < $niclist
+
+@@ -95,15 +64,8 @@ if [ -d "$scriptsdir" ]; then
+ done
+ fi
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" restart
+- # Continue even if the networking init script wasn't successful.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++# Continue even if the networking init script wasn't successful.
++status=0
+
+ if [ $status -eq 0 ]; then
+ rescue_NIC
+diff --git a/scripts/linux/suspend-vm-default b/scripts/linux/suspend-vm-default
+index 80bf5b9..f590194 100644
+--- a/scripts/linux/suspend-vm-default
++++ b/scripts/linux/suspend-vm-default
+@@ -25,37 +25,6 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ save_active_NIC_list() {
+ ifconfig_path=`which ifconfig 2>/dev/null`
+ if [ $? ]; then
+@@ -76,15 +45,12 @@ fi
+
+ save_active_NIC_list
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" stop
+- # If the network is down, this may fail but that's not a good reason
+- # to prevent the suspend.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++for network in `ls /etc/init.d/net.*`;
++do
++ "$network" stop
++done
++# If the network is down, this may fail but that's not a good reason
++# to prevent the suspend.
++status=0
+
+ exit "$status"
diff --git a/app-emulation/open-vm-tools/files/disable-toolbox.patch b/app-emulation/open-vm-tools/files/disable-toolbox.patch
deleted file mode 100644
index 84f97bc65f04..000000000000
--- a/app-emulation/open-vm-tools/files/disable-toolbox.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -ruN open-vm-tools-2007.09.04-56574.orig/configure open-vm-tools-2007.09.04-56574/configure
---- open-vm-tools-2007.09.04-56574.orig/configure 2007-09-07 09:05:19.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/configure 2007-09-14 22:26:20.000000000 +0200
-@@ -25442,7 +25442,7 @@
- ###
- ### Create the Makefiles
- ###
--ac_config_files="$ac_config_files Makefile lib/Makefile lib/atomic/Makefile lib/atomic/shared/Makefile lib/auth/Makefile lib/backdoor/Makefile lib/backdoor/shared/Makefile lib/conf/Makefile lib/dict/Makefile lib/dnd/Makefile lib/err/Makefile lib/eventManager/Makefile lib/file/Makefile lib/fileUtf8/Makefile lib/foundryMsg/Makefile lib/guestApp/Makefile lib/guestInfo/Makefile lib/hgfs/Makefile lib/hgfsBd/Makefile lib/hgfsServer/Makefile lib/hgfsServerManagerGuest/Makefile lib/hgfsServerPolicyGuest/Makefile lib/deployPkg/Makefile lib/impersonate/Makefile lib/message/Makefile lib/message/shared/Makefile lib/misc/Makefile lib/misc/shared/Makefile lib/netUtil/Makefile lib/panic/Makefile lib/panicDefault/Makefile lib/printer/Makefile lib/procMgr/Makefile lib/rpcIn/Makefile lib/rpcOut/Makefile lib/rpcOut/shared/Makefile lib/rpcVmx/Makefile lib/SLPv2Parser/Makefile lib/socketMgr/Makefile lib/strUtil/Makefile lib/string/Makefile lib/string/shared/Makefile lib/sync/Makefile lib/sync/shared/Makefile lib/syncDriver/Makefile lib/system/Makefile lib/toolsLogger/Makefile lib/user/Makefile lib/vixTools/Makefile lib/vmBackupLib/Makefile lib/vmCheck/Makefile lib/vmSignal/Makefile lib/wiper/Makefile guestd/Makefile vmware-user/Makefile toolbox/Makefile hgfsclient/Makefile hgfsmounter/Makefile checkvm/Makefile libguestlib/Makefile"
-+ac_config_files="$ac_config_files Makefile lib/Makefile lib/atomic/Makefile lib/atomic/shared/Makefile lib/auth/Makefile lib/backdoor/Makefile lib/backdoor/shared/Makefile lib/conf/Makefile lib/dict/Makefile lib/dnd/Makefile lib/err/Makefile lib/eventManager/Makefile lib/file/Makefile lib/fileUtf8/Makefile lib/foundryMsg/Makefile lib/guestApp/Makefile lib/guestInfo/Makefile lib/hgfs/Makefile lib/hgfsBd/Makefile lib/hgfsServer/Makefile lib/hgfsServerManagerGuest/Makefile lib/hgfsServerPolicyGuest/Makefile lib/deployPkg/Makefile lib/impersonate/Makefile lib/message/Makefile lib/message/shared/Makefile lib/misc/Makefile lib/misc/shared/Makefile lib/netUtil/Makefile lib/panic/Makefile lib/panicDefault/Makefile lib/printer/Makefile lib/procMgr/Makefile lib/rpcIn/Makefile lib/rpcOut/Makefile lib/rpcOut/shared/Makefile lib/rpcVmx/Makefile lib/SLPv2Parser/Makefile lib/socketMgr/Makefile lib/strUtil/Makefile lib/string/Makefile lib/string/shared/Makefile lib/sync/Makefile lib/sync/shared/Makefile lib/syncDriver/Makefile lib/system/Makefile lib/toolsLogger/Makefile lib/user/Makefile lib/vixTools/Makefile lib/vmBackupLib/Makefile lib/vmCheck/Makefile lib/vmSignal/Makefile lib/wiper/Makefile guestd/Makefile vmware-user/Makefile hgfsclient/Makefile hgfsmounter/Makefile checkvm/Makefile libguestlib/Makefile"
-
-
- ###
-@@ -26131,7 +26131,7 @@
- "lib/wiper/Makefile") CONFIG_FILES="$CONFIG_FILES lib/wiper/Makefile" ;;
- "guestd/Makefile") CONFIG_FILES="$CONFIG_FILES guestd/Makefile" ;;
- "vmware-user/Makefile") CONFIG_FILES="$CONFIG_FILES vmware-user/Makefile" ;;
-- "toolbox/Makefile") CONFIG_FILES="$CONFIG_FILES toolbox/Makefile" ;;
-+ "") CONFIG_FILES="$CONFIG_FILES " ;;
- "hgfsclient/Makefile") CONFIG_FILES="$CONFIG_FILES hgfsclient/Makefile" ;;
- "hgfsmounter/Makefile") CONFIG_FILES="$CONFIG_FILES hgfsmounter/Makefile" ;;
- "checkvm/Makefile") CONFIG_FILES="$CONFIG_FILES checkvm/Makefile" ;;
-diff -ruN open-vm-tools-2007.09.04-56574.orig/Makefile.am open-vm-tools-2007.09.04-56574/Makefile.am
---- open-vm-tools-2007.09.04-56574.orig/Makefile.am 2007-09-07 09:05:07.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/Makefile.am 2007-09-14 22:26:12.000000000 +0200
-@@ -22,7 +22,6 @@
- SUBDIRS += lib
- SUBDIRS += guestd
- SUBDIRS += vmware-user
--SUBDIRS += toolbox
- SUBDIRS += hgfsclient
- # hgfsmounter is only needed on Linux.
- if LINUX
-diff -ruN open-vm-tools-2007.09.04-56574.orig/Makefile.in open-vm-tools-2007.09.04-56574/Makefile.in
---- open-vm-tools-2007.09.04-56574.orig/Makefile.in 2007-09-07 09:05:23.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/Makefile.in 2007-09-14 22:26:01.000000000 +0200
-@@ -79,7 +79,7 @@
- distclean-recursive maintainer-clean-recursive
- ETAGS = etags
- CTAGS = ctags
--DIST_SUBDIRS = lib guestd vmware-user toolbox hgfsclient hgfsmounter \
-+DIST_SUBDIRS = lib guestd vmware-user hgfsclient hgfsmounter \
- checkvm libguestlib
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
-@@ -220,7 +220,7 @@
- target_alias = @target_alias@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = lib guestd vmware-user toolbox hgfsclient $(am__append_1) \
-+SUBDIRS = lib guestd vmware-user hgfsclient $(am__append_1) \
- checkvm libguestlib
- MODULES = vmblock vmhgfs vmmemctl vmxnet
- all: all-recursive