summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-05-01 16:08:37 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-05-01 16:08:37 +0000
commit71f27d252c83af652712b61312d5b84e0f123901 (patch)
tree60402dda531b312917b2ed7026ae29552995b1d1 /app-emulation/point2play
parentfix sandboxing issues (diff)
downloadhistorical-71f27d252c83af652712b61312d5b84e0f123901.tar.gz
historical-71f27d252c83af652712b61312d5b84e0f123901.tar.bz2
historical-71f27d252c83af652712b61312d5b84e0f123901.zip
initial import bug #19989
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog7
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.0.10
-rw-r--r--app-emulation/point2play/point2play-1.0.1.ebuild45
3 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
new file mode 100644
index 000000000000..a089d651048e
--- /dev/null
+++ b/app-emulation/point2play/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for app-emulation/point2play
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.1 2003/05/01 16:08:37 lordvan Exp $
+
+*point2play-1.0.1 (01 May 2003)
+ 01 May 2003; Thomas Raschbacher <lordvan@gentoo.org> point2play-1.0.1.ebuild:
+ initial version bug #19989
diff --git a/app-emulation/point2play/files/digest-point2play-1.0.1 b/app-emulation/point2play/files/digest-point2play-1.0.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.0.1
diff --git a/app-emulation/point2play/point2play-1.0.1.ebuild b/app-emulation/point2play/point2play-1.0.1.ebuild
new file mode 100644
index 000000000000..3433391f1f46
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.0.1.ebuild,v 1.1 2003/05/01 16:08:37 lordvan Exp $
+
+IUSE=""
+
+MY_P="${PN}-small-${PV}"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="3"
+KEYWORDS="~x86"
+LICENSE="Aladdin" # not sure about that .. comments?
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.0
+ >=dev-python/pygtk-1.99.16
+ >=x11-themes/gtk-engines-metal-2.2.0"
+ # Homepage says it needs gtk2-engines .. that shoudl do ..
+DEPEND="${RDEPEND}"
+
+src_unpack () {
+ if [ ! -e "${DISTDIR}/${MY_P}.tgz" ] ; then
+ eerror ""
+ eerror "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
+ eerror ""
+ eerror "The archive should be placed into ${DISTDIR}."
+ eerror ""
+
+ die "package archive (${MY_P}.tgz) not found"
+ fi
+ unpack "${MY_P}.tgz"
+}
+
+src_compile() {
+ # nothing to compile
+ echo ""
+}
+
+src_install () {
+ mv "${WORKDIR}/usr" "${D}"
+ # not handling /etc for now since i'm not sure about kde/gnome directory conventions
+}
+