summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-04 14:40:35 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-04 14:40:35 +0000
commit826e75247f1f856e23363f44b56fdb9ed4587990 (patch)
tree3fe3728d83f4b9c9551b119fb5353521f4ebb2fa /app-emulation/simh/simh-3.7.0.ebuild
parentStable on sparc, bug #252432 (diff)
downloadhistorical-826e75247f1f856e23363f44b56fdb9ed4587990.tar.gz
historical-826e75247f1f856e23363f44b56fdb9ed4587990.tar.bz2
historical-826e75247f1f856e23363f44b56fdb9ed4587990.zip
QA: Define IUSE, use edos2unix, respect CC, respect CFLAGS, fix compilation with --as-needed (bug 246890)
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28 x86_64
Diffstat (limited to 'app-emulation/simh/simh-3.7.0.ebuild')
-rw-r--r--app-emulation/simh/simh-3.7.0.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/app-emulation/simh/simh-3.7.0.ebuild b/app-emulation/simh/simh-3.7.0.ebuild
index 943692011019..22ec46d115d4 100644
--- a/app-emulation/simh/simh-3.7.0.ebuild
+++ b/app-emulation/simh/simh-3.7.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.7.0.ebuild,v 1.3 2008/02/05 21:30:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.7.0.ebuild,v 1.4 2009/01/04 14:40:35 angelos Exp $
-inherit eutils versionator
+inherit eutils toolchain-funcs versionator
MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
@@ -12,6 +12,7 @@ SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
RDEPEND="net-libs/libpcap"
DEPEND="${RDEPEND}
@@ -26,9 +27,13 @@ src_unpack() {
unpack ${A}
# convert makefile from dos format to unix format
- sed -i 's/.$//' makefile
+ edos2unix makefile
- epatch "${FILESDIR}/makefile.patch"
+ sed -i -e "s:gcc:$(tc-getCC):" \
+ -e "s: -g::" \
+ -e "s:-O2:${CFLAGS}:" makefile
+ epatch "${FILESDIR}/makefile.patch" \
+ "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {
@@ -41,7 +46,7 @@ src_install() {
newbin ${BINFILE} "simh-${BINFILE}"
done
- cd ${S}
+ cd "${S}"
dodir /usr/share/simh
insinto /usr/share/simh
doins VAX/*.bin