summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 00:18:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 00:18:15 +0000
commitee32cc2326abec24a3bd81195651ad0dd92d2df6 (patch)
treef9666a64568e518caec7f38f0385d677d364c955 /app-emulation/softgun/softgun-0.11.ebuild
parentAdd support for USE=zlib #79179 by Stefan Riemer. (diff)
downloadhistorical-ee32cc2326abec24a3bd81195651ad0dd92d2df6.tar.gz
historical-ee32cc2326abec24a3bd81195651ad0dd92d2df6.tar.bz2
historical-ee32cc2326abec24a3bd81195651ad0dd92d2df6.zip
Version bump by Yuri Vasilevski.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-emulation/softgun/softgun-0.11.ebuild')
-rw-r--r--app-emulation/softgun/softgun-0.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/softgun/softgun-0.11.ebuild b/app-emulation/softgun/softgun-0.11.ebuild
new file mode 100644
index 000000000000..1aeca261b941
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.11.ebuild,v 1.1 2005/08/18 00:18:15 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install prefix="${D}/usr" || die "Install failed"
+ dodoc README configs/defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}