summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-12 19:50:34 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-12 19:50:34 +0000
commit0d76c05cc21e7f742cb17ba20e8b2dd1a2cd1bb0 (patch)
tree7adfd8d49f83f0ed8d5efffd77acade8cebe11bc /app-emulation/wine
parentclean old; tidy (diff)
downloadhistorical-0d76c05cc21e7f742cb17ba20e8b2dd1a2cd1bb0.tar.gz
historical-0d76c05cc21e7f742cb17ba20e8b2dd1a2cd1bb0.tar.bz2
historical-0d76c05cc21e7f742cb17ba20e8b2dd1a2cd1bb0.zip
Version bump #81688 by Rich.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-200502111
-rw-r--r--app-emulation/wine/wine-20050211.ebuild107
4 files changed, 117 insertions, 2 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 0f8ec40e3045..ada8f0872b94 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.86 2005/01/13 01:12:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.87 2005/02/12 19:50:34 vapier Exp $
+
+*wine-20050211 (12 Feb 2005)
+
+ 12 Feb 2005; Mike Frysinger <vapier@gentoo.org> +wine-20050211.ebuild:
+ Version bump #81688 by Rich.
*wine-20050111 (12 Jan 2005)
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 046f6b85d2e9..966ffcd9a6e4 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,10 +1,11 @@
-MD5 4ddfdf208c433f355ebbee4be1d1a206 ChangeLog 15430
+MD5 17fe357006f311d06238128a1803b18a ChangeLog 15565
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 ce049740347eedc6103976f50c703f85 wine-20040716.ebuild 3447
MD5 96ec146b6ad1dc2bf88ea5669c8d2c15 wine-20041201.ebuild 2932
MD5 ab7f072d035ab1544957ae8a0a595843 wine-20041019-r3.ebuild 2932
MD5 1fcec66c3a3db069065a704291b8b4c4 wine-20041019.ebuild 3772
MD5 9940abbb71d0b977b98493d04b1f478f wine-20050111.ebuild 2951
+MD5 77bdbb830a681c45ce8d9af7f264a3f6 wine-20050211.ebuild 2952
MD5 2cabd57e6a96800a8c7835b0fe1f437a files/digest-wine-20041201 67
MD5 9dbf73d557110996f187b6ed6ae4f7ea files/20041019-load-wrappers.patch 1333
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
@@ -14,3 +15,4 @@ MD5 64c9b939319110b4f44ef6f431262181 files/digest-wine-20041019 212
MD5 b1893ef0ed5c38dabcbea9fcc3d35f59 files/digest-wine-20040716 212
MD5 d9e9a2cb6521b07ace7e7c142679b85b files/20041019-no-stack.patch 257
MD5 8028af5342611d0521183f95342f787a files/digest-wine-20050111 67
+MD5 fe364ce26a93f838a04f30b274df034c files/digest-wine-20050211 67
diff --git a/app-emulation/wine/files/digest-wine-20050211 b/app-emulation/wine/files/digest-wine-20050211
new file mode 100644
index 000000000000..5c4d14d7d275
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20050211
@@ -0,0 +1 @@
+MD5 19c532b9b344d1b197ee8d55289ebf1c Wine-20050211.tar.gz 11626818
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
new file mode 100644
index 000000000000..9150e272f5d5
--- /dev/null
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.1 2005/02/12 19:50:34 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
+RESTRICT="maketest" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( virtual/x11 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/bison
+ sys-devel/gcc
+ doc? ( app-text/docbook-sgml-utils app-text/jadetex )
+ sys-devel/flex"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack header_jack_jack_h
+ config_cache cups header_cups_cups_h
+ config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas header_audio_audiolib_h header_audio_soundlib_h
+ config_cache gif header_gif_lib_h
+ config_cache glut lib_glut_glutMainLoop
+ config_cache jpeg header_jpeglib_h
+ config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
+ config_cache lcms header_lcms_h
+
+ strip-flags
+ use lcms && append-flags -I${ROOT}/usr/include/lcms
+
+ # $(use_enable amd64 win64)
+ # USE=debug is broken in this release
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+ if use doc ; then
+ emake -j1 -C documentation doc || die "docs"
+ fi
+}
+
+src_install() {
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ datadir="${D}"/usr/share \
+ includedir="${D}"/usr/include/wine \
+ sysconfdir="${D}"/etc/wine \
+ mandir="${D}"/usr/share/man \
+ libdir="${D}"/usr/lib \
+ dlldir="${D}"/usr/lib/wine \
+ install || die
+ use doc && dodoc documentation/*.pdf
+
+ insinto /usr/share/wine
+ doins documentation/samples/config || die "doins config"
+
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+}