summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-10-22 13:06:50 +0000
committerDavid Holm <dholm@gentoo.org>2004-10-22 13:06:50 +0000
commitf44c605fcc9e760af19fc3e3717e96644a676c7a (patch)
tree60c60cd78d2ea1688041a2fc04c63436904d6069 /app-emulation
parentmake sure we call the right unpack func when using cvs (diff)
downloadhistorical-f44c605fcc9e760af19fc3e3717e96644a676c7a.tar.gz
historical-f44c605fcc9e760af19fc3e3717e96644a676c7a.tar.bz2
historical-f44c605fcc9e760af19fc3e3717e96644a676c7a.zip
Initial import
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/e-uae/ChangeLog10
-rw-r--r--app-emulation/e-uae/Manifest5
-rw-r--r--app-emulation/e-uae/e-uae-0.8.27_rc1.ebuild74
-rw-r--r--app-emulation/e-uae/files/digest-e-uae-0.8.27_rc11
-rw-r--r--app-emulation/e-uae/files/e-uae-0.8.27_rc1-keymap-fix.diff19
-rw-r--r--app-emulation/e-uae/metadata.xml12
-rw-r--r--app-emulation/uae/Manifest12
7 files changed, 126 insertions, 7 deletions
diff --git a/app-emulation/e-uae/ChangeLog b/app-emulation/e-uae/ChangeLog
new file mode 100644
index 000000000000..ebaeeeec79e3
--- /dev/null
+++ b/app-emulation/e-uae/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/e-uae
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/ChangeLog,v 1.1 2004/10/22 13:06:50 dholm Exp $
+
+*e-uae-0.8.27_rc1 (22 Oct 2004)
+
+ 22 Oct 2004; David Holm <dholm@gentoo.org> +metadata.xml,
+ +files/e-uae-0.8.27_rc1-keymap-fix.diff, +e-uae-0.8.27_rc1.ebuild:
+ E-UAE is a fork of UAE by Richard Drummond
+
diff --git a/app-emulation/e-uae/Manifest b/app-emulation/e-uae/Manifest
new file mode 100644
index 000000000000..9c9a3301e5d7
--- /dev/null
+++ b/app-emulation/e-uae/Manifest
@@ -0,0 +1,5 @@
+MD5 4390c64abb02ec73ef5e8e28965f2fec e-uae-0.8.27_rc1.ebuild 1902
+MD5 47efa1259484ff2a7d3de539d42b1a90 metadata.xml 371
+MD5 44beed859c6a9a30a3667f0cc8e77324 ChangeLog 418
+MD5 ee7214e4517e86c3680b0cd0790a53f2 files/e-uae-0.8.27_rc1-keymap-fix.diff 618
+MD5 01527804b272a587374f80d295b338a6 files/digest-e-uae-0.8.27_rc1 70
diff --git a/app-emulation/e-uae/e-uae-0.8.27_rc1.ebuild b/app-emulation/e-uae/e-uae-0.8.27_rc1.ebuild
new file mode 100644
index 000000000000..5fb28be3a9a3
--- /dev/null
+++ b/app-emulation/e-uae/e-uae-0.8.27_rc1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/e-uae/e-uae-0.8.27_rc1.ebuild,v 1.1 2004/10/22 13:06:50 dholm Exp $
+
+inherit eutils flag-o-matic
+
+MY_PV="0.8.27-RC1"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="The Umiquious Amiga Emulator"
+HOMEPAGE="http://www.rcdrummond.net/uae/"
+SRC_URI="http://www.rcdrummond.net/uae/${PN}-${MY_PV}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="X gtk sdl ncurses svga"
+
+DEPEND="virtual/libc
+ X? (
+ virtual/x11
+ gtk? ( >=x11-libs/gtk+-2.0.0 )
+ )
+ !X? (
+ ncurses? ( sys-libs/ncurses )
+ svga? ( media-libs/svgalib )
+ )
+ sdl? ( media-libs/libsdl )
+ app-cdr/cdrtools
+ games-emulation/caps"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-keymap-fix.diff
+}
+
+src_compile() {
+ # -O3 breaks compilation, GCC will eat all your RAM + Swap and die
+ replace-flags "-O3" "-O2"
+ use x86 && strip-flags "-msse" "-msse2"
+ use ppc && strip-flags "-maltivec" "-mabi=altivec"
+ use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
+
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+ ./bootstrap.sh || die "bootstrap failed"
+ econf ${myconf} \
+ --enable-threads \
+ --enable-cdtv \
+ --enable-cd32 \
+ --enable-scsi-device \
+ --enable-bsdsock \
+ --with-libscg-includedir=/usr/include/scsilib \
+ || die "./configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ cp docs/unix/README docs/README.unix
+ dodoc docs/COMPATIBILITY docs/CREDITS docs/FAQ docs/NEWS \
+ docs/README docs/README.PROGRAMMERS docs/README.unix \
+ docs/translated/*
+
+ emake install DESTDIR=${D}
+
+ insinto /usr/share/uae/amiga-tools
+ doins amiga/{*hack,trans*,uae*,*.library}
+
+ # Rename it to e-uae
+ mv ${D}/usr/bin/uae ${D}/usr/bin/e-uae
+ mv ${D}/usr/bin/readdisk ${D}/usr/bin/e-readdisk
+ mv ${D}/usr/share/uae ${D}/usr/share/${PN}
+}
diff --git a/app-emulation/e-uae/files/digest-e-uae-0.8.27_rc1 b/app-emulation/e-uae/files/digest-e-uae-0.8.27_rc1
new file mode 100644
index 000000000000..a730558d58ae
--- /dev/null
+++ b/app-emulation/e-uae/files/digest-e-uae-0.8.27_rc1
@@ -0,0 +1 @@
+MD5 aa051efc5fccbbc22b426daf1d287196 e-uae-0.8.27-RC1.tar.bz2 1088586
diff --git a/app-emulation/e-uae/files/e-uae-0.8.27_rc1-keymap-fix.diff b/app-emulation/e-uae/files/e-uae-0.8.27_rc1-keymap-fix.diff
new file mode 100644
index 000000000000..af6220dc9ace
--- /dev/null
+++ b/app-emulation/e-uae/files/e-uae-0.8.27_rc1-keymap-fix.diff
@@ -0,0 +1,19 @@
+--- /home/evilrich/e-uae-0.8.27-RC1/src/keymap/keymap.c 2004-10-06 04:01:47.000000000 -0500
++++ src/keymap/keymap.c 2004-10-18 00:39:18.000000000 -0500
+@@ -168,13 +168,15 @@
+ count = i;
+
+ trans = (struct uae_input_device_kbr_default*)
+- malloc (sizeof (struct uae_input_device_kbr_default) * count);
++ malloc (sizeof (struct uae_input_device_kbr_default) * (count + 1));
+
+ if (trans) {
+ for (i = 0; i < count; i++) {
+ trans[i].scancode = hostkeys[i].hostkey;
+ trans[i].event = default_keymap[hostkeys[i].uaekey];
+ }
++ trans[i].scancode = -1;
+ }
++
+ return trans;
+ };
diff --git a/app-emulation/e-uae/metadata.xml b/app-emulation/e-uae/metadata.xml
new file mode 100644
index 000000000000..5cc07509bfa6
--- /dev/null
+++ b/app-emulation/e-uae/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dholm@gentoo.org</email>
+ <name>David Holm</name>
+</maintainer>
+<longdescription>
+E-UAE is a fork of UAE which intends to merge all the new features of WinUAE with UAE.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/uae/Manifest b/app-emulation/uae/Manifest
index f8f5e9506ce9..3f88a5d874bc 100644
--- a/app-emulation/uae/Manifest
+++ b/app-emulation/uae/Manifest
@@ -1,11 +1,9 @@
-MD5 3229ade24425de89f455c4663c9fc82c ChangeLog 3480
+MD5 5b98579e07813468defb7e4f12c18364 ChangeLog 3821
MD5 800d59bca6b74f54268ca8c63af928ee metadata.xml 668
-MD5 af8db5e7e94c29b370ea7f832f4506c4 uae-0.8.22.ebuild 1279
-MD5 29d8dc818001e2f0ce15c9effdc2b36b uae-0.8.25_pre20040302.ebuild 1819
-MD5 fc08732cc66e88f1f844894394064d3b uae-0.8.27_pre20040720.ebuild 2120
+MD5 ef6b8a0850887e94b162e9cee9fd3eab uae-0.8.22-r1.ebuild 1383
+MD5 d3ad82afab7d2d7988c5b322e9a9ff12 uae-0.8.22.ebuild 1277
MD5 b2fac0f21ee34abaa6279cf7ad023119 files/digest-uae-0.8.22 62
-MD5 02f734719ea8dc27787fb6be6ddcc11e files/digest-uae-0.8.25_pre20040302 73
MD5 77b204c71d52f0a0423054b5a9b8a0cb files/split_cpuemu.pl 498
MD5 4d3af2d2cc2945b006249066cb8c7adb files/uae-patch.diff 364
-MD5 892f9c2140ccb66fdb1b3900cbc4de9f files/uae-0.8.27_pre20040720-ppc-asm-fix.patch 1232
-MD5 4e6bc702ce0118f127154bddd790fdda files/digest-uae-0.8.27_pre20040720 72
+MD5 827829b7999933c091736f210ef9903e files/uae-0.8.22-alsa-support.diff 10321
+MD5 b2fac0f21ee34abaa6279cf7ad023119 files/digest-uae-0.8.22-r1 62