summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-03-24 17:29:23 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-03-24 17:29:23 +0000
commit06ead6c2a6e1fd1936e68652dbee7bc4d23ac6ca (patch)
tree837d7db7f9f6ddd0f2b1c85e4655088513e57d90 /app-forensics/lynis/lynis-1.2.4.ebuild
parentPush hardened/x86/2.6 down to hardened/x86 take two (diff)
downloadhistorical-06ead6c2a6e1fd1936e68652dbee7bc4d23ac6ca.tar.gz
historical-06ead6c2a6e1fd1936e68652dbee7bc4d23ac6ca.tar.bz2
historical-06ead6c2a6e1fd1936e68652dbee7bc4d23ac6ca.zip
Version bump to 1.2.4, using einfo instead of elog.
Package-Manager: portage-2.2_rc26/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/lynis/lynis-1.2.4.ebuild')
-rw-r--r--app-forensics/lynis/lynis-1.2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-forensics/lynis/lynis-1.2.4.ebuild b/app-forensics/lynis/lynis-1.2.4.ebuild
new file mode 100644
index 000000000000..9798882b828d
--- /dev/null
+++ b/app-forensics/lynis/lynis-1.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/lynis/lynis-1.2.4.ebuild,v 1.1 2009/03/24 17:29:23 idl0r Exp $
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="http://www.rootkit.nl/projects/lynis.html"
+SRC_URI="http://www.rootkit.nl/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/ || die "failed to install lynis base files"
+
+ dosbin lynis || die "dosbin failed"
+
+ insinto /etc/${PN}
+ doins default.prf || die "failed to install default.prf"
+
+ doman lynis.8 || die "doman failed"
+ dodoc CHANGELOG FAQ README TODO || die "dodoc failed"
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis || die "failed to install cron script"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}