summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-11-26 07:40:04 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-11-26 07:40:04 +0000
commit5d8bd7b6c9cfb6148698641f5f33e5d4b9827e0b (patch)
treeaf79dd96f38e80db22fc1fe9f7ac9ab7f59d1cd6 /app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild
parentStable on hppa and ia64. (diff)
downloadhistorical-5d8bd7b6c9cfb6148698641f5f33e5d4b9827e0b.tar.gz
historical-5d8bd7b6c9cfb6148698641f5f33e5d4b9827e0b.tar.bz2
historical-5d8bd7b6c9cfb6148698641f5f33e5d4b9827e0b.zip
Re-committing, this time with the correct file name...
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild')
-rw-r--r--app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild b/app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild
new file mode 100644
index 000000000000..610f623c0231
--- /dev/null
+++ b/app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook-svn/omnibook-svn-20071231.ebuild,v 1.1 2007/11/26 07:40:03 s4t4n Exp $
+
+inherit linux-mod subversion
+
+ESVN_REPO_URI="https://omnibook.svn.sourceforge.net/svnroot/omnibook/omnibook/trunk"
+ESVN_PROJECT="omnibook"
+
+DESCRIPTION="Linux kernel module for (but not limited to) HP Omnibook support"
+HOMEPAGE="http://www.sourceforge.net/projects/omnibook"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 -ppc"
+IUSE=""
+
+MODULE_NAMES="omnibook(char:)"
+BUILD_TARGETS=" "
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL=${KV_MAJOR}.${KV_MINOR} KSRC=${KV_DIR}"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ dodoc doc/*
+ docinto misc
+ dodoc misc/*.patch misc/*.txt
+ docinto hotkeys
+ dodoc misc/hotkeys/*
+
+ linux-mod_src_install
+}