summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:43:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:43:54 +0000
commitad3b0b383f9ec3c9708bc1a27c74898068f21264 (patch)
treead64814a7a40377b89b94576290ea2822bc8991e /app-misc/countrycodes
parentdon't assign default to S; depend on sed >= 4; error check sed; use user CFLA... (diff)
downloadhistorical-ad3b0b383f9ec3c9708bc1a27c74898068f21264.tar.gz
historical-ad3b0b383f9ec3c9708bc1a27c74898068f21264.tar.bz2
historical-ad3b0b383f9ec3c9708bc1a27c74898068f21264.zip
don't assign default to S; don't rdepend on sed; use emake; install man pages in proper location; tidy
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/ChangeLog7
-rw-r--r--app-misc/countrycodes/Manifest4
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5.ebuild25
3 files changed, 23 insertions, 13 deletions
diff --git a/app-misc/countrycodes/ChangeLog b/app-misc/countrycodes/ChangeLog
index 0e4fb1f9a960..45978a2986da 100644
--- a/app-misc/countrycodes/ChangeLog
+++ b/app-misc/countrycodes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/countrycodes
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.1 2004/02/29 22:10:15 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.2 2004/04/10 09:43:54 mr_bones_ Exp $
+
+ 10 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ countrycodes-1.0.5.ebuild:
+ don't assign default to S; don't rdepend on sed; use emake; install man pages
+ in proper location; tidy
*countrycodes-1.0.5 (29 Feb 2004)
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
index a814d7b93f56..45b7a4365656 100644
--- a/app-misc/countrycodes/Manifest
+++ b/app-misc/countrycodes/Manifest
@@ -1,3 +1,3 @@
-MD5 0ee1730a462a291dd0284fbad1b5954c ChangeLog 429
-MD5 146cf0173386f41b44d773aebd1a755f countrycodes-1.0.5.ebuild 773
+MD5 62779bc65ec8bf915dd1355777198067 ChangeLog 622
+MD5 3da5f8ff884f764daa68b833381b3454 countrycodes-1.0.5.ebuild 896
MD5 4f42346a15ab781a4585f7254b5e35e7 files/digest-countrycodes-1.0.5 69
diff --git a/app-misc/countrycodes/countrycodes-1.0.5.ebuild b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
index 6ecf73434bf3..2e3cdadf3dcd 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5.ebuild
@@ -1,27 +1,32 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.1 2004/02/29 22:10:15 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5.ebuild,v 1.2 2004/04/10 09:43:54 mr_bones_ Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="An ISO 3166 country code finder."
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
-KEYWORDS="~x86"
SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~x86"
IUSE=""
-DEPEND="virtual/glibc
-sys-apps/sed"
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
src_compile() {
- make -C src $MAKEOPTS CCOPTS="$CFLAGS" || die
+ emake -C src $MAKEOPTS CCOPTS="$CFLAGS" || die "emake failed"
}
src_install () {
- dodir /usr/bin
- dodir /usr/man/man1
- make -C src prefix=${D}/usr install || die
+ dodir /usr/bin /usr/share/man/man1
+ make \
+ -C src \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
dosym iso3166 /usr/bin/countrycodes
- dodoc doc/Changelog doc/README doc/COPYING doc/INSTALL
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc doc/{Changelog,README}
+ prepman
}