summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-17 00:52:13 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-17 00:52:13 +0000
commite8ba9535513b7eb237def291d97c2c1a4dea2751 (patch)
tree1c748825208e14c8caef0581de4472ef70933c60 /app-misc
parentHeader fixes (diff)
downloadhistorical-e8ba9535513b7eb237def291d97c2c1a4dea2751.tar.gz
historical-e8ba9535513b7eb237def291d97c2c1a4dea2751.tar.bz2
historical-e8ba9535513b7eb237def291d97c2c1a4dea2751.zip
lintool fixes
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/oneko/oneko-1.2.ebuild11
-rw-r--r--app-misc/read-edid/read-edid-1.4.1.ebuild8
-rw-r--r--app-misc/sonypid/sonypid-1.0.20010123.ebuild10
-rw-r--r--app-misc/sonypid/sonypid-20010123.ebuild9
-rw-r--r--app-misc/spicctrl/spicctrl-1.2.ebuild7
-rw-r--r--app-misc/spicctrl/spicctrl-1.3.ebuild4
-rw-r--r--app-misc/tinyca/tinyca-0.4.2.ebuild3
7 files changed, 27 insertions, 25 deletions
diff --git a/app-misc/oneko/oneko-1.2.ebuild b/app-misc/oneko/oneko-1.2.ebuild
index df6fa9364871..d6c62660b679 100644
--- a/app-misc/oneko/oneko-1.2.ebuild
+++ b/app-misc/oneko/oneko-1.2.ebuild
@@ -1,6 +1,6 @@
-#Copyright 2002 Gentoo Technologies, Inc.
-#Distributed under the terms of the GNU General Public License v2
-#$Header: /var/cvsroot/gentoo-x86/app-misc/oneko/oneko-1.2.ebuild,v 1.2 2002/07/25 19:18:34 seemant Exp $
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/oneko/oneko-1.2.ebuild,v 1.3 2002/10/17 00:46:23 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A cat (or dog) which chases the mouse around the screen"
@@ -12,15 +12,14 @@ LICENSE="BSD"
KEYWORDS="x86"
DEPEND="x11-base/xfree"
+RDEPEND="${DEPEND}"
src_compile() {
-
xmkmf -a || die
emake || die
}
-src_install () {
-
+src_install() {
into /usr
dobin oneko
mv oneko._man oneko.1x
diff --git a/app-misc/read-edid/read-edid-1.4.1.ebuild b/app-misc/read-edid/read-edid-1.4.1.ebuild
index 327c25b68091..3cc77a607524 100644
--- a/app-misc/read-edid/read-edid-1.4.1.ebuild
+++ b/app-misc/read-edid/read-edid-1.4.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/read-edid/read-edid-1.4.1.ebuild,v 1.3 2002/07/26 02:16:31 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/read-edid/read-edid-1.4.1.ebuild,v 1.4 2002/10/17 00:47:31 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Read edid is a program that can get information from a pnp monitor."
HOMEPAGE="http://john.fremlin.de/programs/linux/read-edid/index.html"
-DEPEND=""
-#RDEPEND=""
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
SRC_URI="http://john.fremlin.de/programs/linux/read-edid/${P}.tar.gz"
SLOT="0"
@@ -18,7 +18,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog LRMI NEWS README
diff --git a/app-misc/sonypid/sonypid-1.0.20010123.ebuild b/app-misc/sonypid/sonypid-1.0.20010123.ebuild
index a8adf315c713..3f017556be48 100644
--- a/app-misc/sonypid/sonypid-1.0.20010123.ebuild
+++ b/app-misc/sonypid/sonypid-1.0.20010123.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sonypid/sonypid-1.0.20010123.ebuild,v 1.1 2002/10/15 10:05:52 hanno Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sonypid/sonypid-1.0.20010123.ebuild,v 1.2 2002/10/17 00:51:34 vapier Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="sonypid - a tool to use the Sony Vaios jog-dial as a mouse-wheel"
@@ -12,12 +11,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64"
-DEPEND=""
+DEPEND="virtual/kernel"
+RDEPEND="${DEPEND}"
src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes -I/usr/src/linux/include" || die
}
-src_install () {
- dobin sonypid
+src_install() {
+ dobin sonypid
}
diff --git a/app-misc/sonypid/sonypid-20010123.ebuild b/app-misc/sonypid/sonypid-20010123.ebuild
index 7597d9ed5ec6..76236f4dd6da 100644
--- a/app-misc/sonypid/sonypid-20010123.ebuild
+++ b/app-misc/sonypid/sonypid-20010123.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sonypid/sonypid-20010123.ebuild,v 1.4 2002/09/23 19:06:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sonypid/sonypid-20010123.ebuild,v 1.5 2002/10/17 00:49:20 vapier Exp $
S=${WORKDIR}/${PN}
@@ -12,12 +12,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64"
-DEPEND=""
+DEPEND="virtual/kernel"
+RDEPEND="${DEPEND}"
src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes -I/usr/src/linux/include" || die
}
-src_install () {
- dobin sonypid
+src_install() {
+ dobin sonypid
}
diff --git a/app-misc/spicctrl/spicctrl-1.2.ebuild b/app-misc/spicctrl/spicctrl-1.2.ebuild
index cac7e391fa3e..99177217f4b8 100644
--- a/app-misc/spicctrl/spicctrl-1.2.ebuild
+++ b/app-misc/spicctrl/spicctrl-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/spicctrl/spicctrl-1.2.ebuild,v 1.2 2002/07/25 19:18:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/spicctrl/spicctrl-1.2.ebuild,v 1.3 2002/10/17 00:52:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="spicctrl 1.2 - Tool for the sonypi-Device (found in Sony Vaio Notebooks)"
@@ -11,12 +11,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64"
-DEPEND=""
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wstrict-prototypes" || die
}
-src_install () {
+src_install() {
dobin spicctrl
}
diff --git a/app-misc/spicctrl/spicctrl-1.3.ebuild b/app-misc/spicctrl/spicctrl-1.3.ebuild
index 0b2e2876719f..177f14a8ac9c 100644
--- a/app-misc/spicctrl/spicctrl-1.3.ebuild
+++ b/app-misc/spicctrl/spicctrl-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/spicctrl/spicctrl-1.3.ebuild,v 1.1 2002/10/13 09:17:56 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/spicctrl/spicctrl-1.3.ebuild,v 1.2 2002/10/17 00:52:13 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="spicctrl - Tool for the sonypi-Device (found in Sony Vaio Notebooks)"
@@ -19,6 +19,6 @@ src_compile() {
emake CFLAGS="${CFLAGS}" || die
}
-src_install () {
+src_install() {
dobin spicctrl
}
diff --git a/app-misc/tinyca/tinyca-0.4.2.ebuild b/app-misc/tinyca/tinyca-0.4.2.ebuild
index f1de915cb1cf..87e8749571dd 100644
--- a/app-misc/tinyca/tinyca-0.4.2.ebuild
+++ b/app-misc/tinyca/tinyca-0.4.2.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tinyca/tinyca-0.4.2.ebuild,v 1.3 2002/10/17 00:50:02 vapier Exp $
S="${WORKDIR}/TinyCA"
DESCRIPTION="Simple Perl/Tk GUI to manage a small certification authority"
@@ -13,7 +14,7 @@ KEYWORDS="x86"
DEPEND=">=dev-libs/openssl-0.9.6b
>=dev-perl/MIME-Base64-2.12
>=dev-perl/perl-tk-800.024"
-
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}