summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2009-08-19 16:10:48 +0000
committerTimo Gurr <tgurr@gentoo.org>2009-08-19 16:10:48 +0000
commit769e895482ebb33d9cfddc97b494590896d2aeb5 (patch)
treea89581bc98fbd440b359cc253328b21cb8864bbf /app-office/kmymoney2/kmymoney2-1.0.0.ebuild
parentmove >=x11-libs/xcb-util-0.3.4 and >=x11-wm/awesome-3.3 to the 2008.0 profiles. (diff)
downloadhistorical-769e895482ebb33d9cfddc97b494590896d2aeb5.tar.gz
historical-769e895482ebb33d9cfddc97b494590896d2aeb5.tar.bz2
historical-769e895482ebb33d9cfddc97b494590896d2aeb5.zip
Version bump to new stable.
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'app-office/kmymoney2/kmymoney2-1.0.0.ebuild')
-rw-r--r--app-office/kmymoney2/kmymoney2-1.0.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-office/kmymoney2/kmymoney2-1.0.0.ebuild b/app-office/kmymoney2/kmymoney2-1.0.0.ebuild
new file mode 100644
index 000000000000..797ed83a42de
--- /dev/null
+++ b/app-office/kmymoney2/kmymoney2-1.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney2/kmymoney2-1.0.0.ebuild,v 1.1 2009/08/19 16:10:48 tgurr Exp $
+
+EAPI="2"
+inherit kde
+
+DESCRIPTION="Personal Finances Manager for KDE."
+HOMEPAGE="http://kmymoney2.sourceforge.net"
+SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt ofx qtdesigner sqlite3 test"
+
+COMMON_DEPEND="dev-libs/libxml2
+ ofx? ( >=dev-libs/libofx-0.8.2
+ || ( dev-cpp/libxmlpp:2.6 >=dev-cpp/libxmlpp-1.0.1:0 )
+ >=net-misc/curl-7.9.7
+ app-text/opensp )
+ sqlite3? ( =dev-db/sqlite-3* )"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ test? ( >=dev-util/cppunit-1.8.0 )"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+need-kde 3.5
+
+src_configure() {
+ local myconf
+ myconf="${myconf} \
+ $(use_enable ofx ofxplugin)
+ $(use_enable ofx ofxbanking)
+ $(use_enable qtdesigner)
+ $(use_enable sqlite3)
+ $(use_enable test cppunit)"
+
+ kde_src_configure
+}
+
+src_test() {
+ # Parallel make check is broken
+ make -j1 check || die "Make check failed!"
+}
+
+pkg_postinst() {
+ echo
+ elog "If you want HBCI support in ${P}, please install app-office/kmm_kbanking separately."
+ echo
+}