summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 13:09:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 13:09:07 +0000
commit14e8500db10b5e02d5f1139fb9c807f42cd99bc0 (patch)
treead28c8399e5bc86c183207c95c6650ef7440074a /app-office/sc/sc-7.12.ebuild
parentrepoman'd (diff)
downloadhistorical-14e8500db10b5e02d5f1139fb9c807f42cd99bc0.tar.gz
historical-14e8500db10b5e02d5f1139fb9c807f42cd99bc0.tar.bz2
historical-14e8500db10b5e02d5f1139fb9c807f42cd99bc0.zip
repoman'd
Diffstat (limited to 'app-office/sc/sc-7.12.ebuild')
-rw-r--r--app-office/sc/sc-7.12.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/app-office/sc/sc-7.12.ebuild b/app-office/sc/sc-7.12.ebuild
index 8814b4d40c8a..2700152bde9e 100644
--- a/app-office/sc/sc-7.12.ebuild
+++ b/app-office/sc/sc-7.12.ebuild
@@ -1,28 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.12.ebuild,v 1.4 2002/08/01 11:40:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.12.ebuild,v 1.5 2002/08/01 13:09:06 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="sc is a free curses-based spreadsheet program that uses key bindings similar to vi and less."
SRC_URI="ftp://ibiblio.org/pub/Linux/apps/financial/spreadsheet/${P}.tar.gz"
HOMEPAGE=""
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2"
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="x86"
+
+DEPEND=">=sys-libs/ncurses-5.2"
src_compile() {
- try make CFLAGS="-DSYSV3 $CFLAGS" prefix=/usr
+ make CFLAGS="-DSYSV3 $CFLAGS" prefix=/usr || die
}
src_install () {
- dodir /usr/bin
- dodir /usr/share/man/man1
- dodir /usr/lib/sc
- try make prefix=${D}/usr MANDIR=${D}/usr/share/man/man1 install
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/lib/sc
+ make prefix=${D}/usr MANDIR=${D}/usr/share/man/man1 install || die
- dodoc CHANGES README sc.doc psc.doc tutorial.sc
- dodoc VMS_NOTES ${P}.lsm TODO SC.MACROS
+ dodoc CHANGES README sc.doc psc.doc tutorial.sc
+ dodoc VMS_NOTES ${P}.lsm TODO SC.MACROS
}
# vim: ai et sw=4 ts=4