summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-08-26 06:35:50 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-08-26 06:35:50 +0000
commit27547eb46f403eaf91284a4e7bf730a0334c5736 (patch)
tree30eacebbe6b54fb88c9dbeaab6a2ef497c0099d8 /app-office/texmacs
parentMarked ~hppa (bug #235533). (diff)
downloadhistorical-27547eb46f403eaf91284a4e7bf730a0334c5736.tar.gz
historical-27547eb46f403eaf91284a4e7bf730a0334c5736.tar.bz2
historical-27547eb46f403eaf91284a4e7bf730a0334c5736.zip
Adding back the previous version which was erroneously removed
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.25-tuxonice-r1 i686
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog6
-rw-r--r--app-office/texmacs/files/texmacs-1.0.6.14.patch110
-rw-r--r--app-office/texmacs/texmacs-1.0.6.14.ebuild64
-rw-r--r--app-office/texmacs/texmacs-1.0.6.15.ebuild4
4 files changed, 181 insertions, 3 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 046fa1cfd150..8591e19da43b 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/texmacs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.64 2008/08/19 05:43:37 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.65 2008/08/26 06:35:49 grozin Exp $
+
+ 26 Aug 2008; Andrey Grozin <grozin@gentoo.org>
+ +texmacs-1.0.6.14.ebuild, +files/texmacs-1.0.6.14.patch:
+ Adding back the previous version which was erroneously removed
*texmacs-1.0.6.15 (19 Aug 2008)
diff --git a/app-office/texmacs/files/texmacs-1.0.6.14.patch b/app-office/texmacs/files/texmacs-1.0.6.14.patch
new file mode 100644
index 000000000000..f2b6d312344f
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.0.6.14.patch
@@ -0,0 +1,110 @@
+diff -r -U2 TeXmacs-1.0.6.14-src.orig/plugins/maxima/bin/maxima_detect TeXmacs-1.0.6.14-src/plugins/maxima/bin/maxima_detect
+--- TeXmacs-1.0.6.14-src.orig/plugins/maxima/bin/maxima_detect 2008-03-19 23:16:36.000000000 +0600
++++ TeXmacs-1.0.6.14-src/plugins/maxima/bin/maxima_detect 2008-08-26 21:11:53.000000000 +0700
+@@ -37,4 +37,26 @@
+ }
+
++# maximum version
++V1=0; V2=0; V3=0
++
++max_ver() {
++ while [ -n "$1" ]; do
++ if [ $1 -gt $V1 ]
++ then V1=$1; V2=$2; V3=$3
++ elif [ $1 -eq $V1 ]
++ then
++ if [ $2 -gt $V2 ]
++ then V2=$2; V3=$3
++ elif [ $2 -eq $V2 ]
++ then
++ if [ $3 -gt $V3 ]
++ then V3=$3
++ fi
++ fi
++ fi
++ shift; shift; shift
++ done
++}
++
+ if [ $OSTYPE = "cygwin" ] ; then EXT='.bat'; else EXT=''; fi
+ MAXIMA=`which maxima$EXT 2>/dev/null`
+@@ -57,16 +79,28 @@
+ if [ "$1" ]
+ then
+- if $MAXIMA --list-avail | grep -F "version 5.9.1
+-version 5.9.2
+-version 5.9.3
+-version 5.10
+-version 5.11
+-version 5.12
+-version 5.13
+-version 5.14" >/dev/null
++ max_ver `maxima --list-avail | \
++ grep '^version [A-Za-z0-9\.]\+, lisp [A_Za-z0-9]\+$' |\
++ sed -e 's/^version \([0-9]\+\)\.\([0-9]\+\)\.\([0-9]\+\).*$/\1 \2 \3/'`
++
++ GOOD=no
++ if [ $V1 -gt 5 ]
++ then GOOD=yes
++ elif [ $V1 -eq 5 ]
++ then
++ if [ $V2 -gt 9 ]
++ then GOOD=yes
++ elif [ $V2 -eq 9 ]
++ then
++ if [ $V3 -gt 0 ]
++ then GOOD=yes
++ fi
++ fi
++ fi
++
++ if [ $GOOD = yes ]
+ then
+- # 5.9.1 or 5.9.2 or 5.9.3 or 5.10 or 5.11 or 5.12 or 5.13 or 5.14
+- maxima -d | grep -F 'maxima-htmldir=' | sed -e \
+- 's/maxima-htmldir=/"/' -e 's|$|/maxima_toc.html"|'
++ # 5.9.1 or later
++ maxima -d | grep -F 'maxima-htmldir=' |\
++ sed -e 's/maxima-htmldir=/"/' -e 's|$|/maxima_toc.html"|'
+ else
+ # 5.9.0
+@@ -74,6 +108,9 @@
+ fi
+ else
+- maxima --list-avail | sed -e '1d' -e 's/version /"/' \
+- -e 's/, lisp / /' -e 's/$/"/' -e '2s/^/(/' -e '$s/$/)/'
++ echo '('
++ maxima --list-avail |\
++ grep '^version [a-z0-9\.]\+, lisp [a-zA-Z0-9]\+$' |\
++ sed -e 's/^version \([a-z0-9\.]\+\), lisp \([a-zA_Z0-9]\+\)$/"\1 \2"/'
++ echo ')'
+ fi
+ else
+diff -r -U2 TeXmacs-1.0.6.14-src.orig/plugins/maxima/bin/tm_maxima TeXmacs-1.0.6.14-src/plugins/maxima/bin/tm_maxima
+--- TeXmacs-1.0.6.14-src.orig/plugins/maxima/bin/tm_maxima 2008-03-19 23:16:36.000000000 +0600
++++ TeXmacs-1.0.6.14-src/plugins/maxima/bin/tm_maxima 2008-08-26 21:12:04.000000000 +0700
+@@ -5,4 +5,5 @@
+
+ case $1 in
++ cygwin) exec maxima.bat -p "`echo $TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp|cygpath --windows -f -`";;
+ 5.6)
+ case $2 in
+@@ -11,14 +12,9 @@
+ clisp) exec maxima -i "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.6.lisp" \
+ | maxima_filter;;
+- *) echo -e "\2latex:\\red Unsupported lisp for old maxima: $2\5"
+ esac;;
+- 5.9.0) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.0.lisp" \
+- | maxima_filter;;
+- 5.9.1) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.1.lisp";;
+- 5.9.1.1* | 5.9.2* | 5.9.3*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.2.lisp";;
++ 5.9.0) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.0.lisp" | maxima_filter;;
++ 5.9.1*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.1.lisp";;
++ 5.9.2* | 5.9.3*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.2.lisp";;
+ 5.10.*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.10.0.lisp";;
+- 5.11.* | 5.12.* | 5.13.* | 5.14.*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp";;
+- cygwin)
+- exec maxima.bat -p "`echo $TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp|cygpath --windows -f -`";;
+- *) echo -e "\2latex:\\red Unsupported version of maxima: $1\5"
++ *) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp";;
+ esac
diff --git a/app-office/texmacs/texmacs-1.0.6.14.ebuild b/app-office/texmacs/texmacs-1.0.6.14.ebuild
new file mode 100644
index 000000000000..227c42ef7f52
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.6.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.6.14.ebuild,v 1.7 2008/08/26 06:35:49 grozin Exp $
+
+inherit eutils
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="imlib jpeg svg netpbm spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/latex-base
+ virtual/ghostscript
+ >=dev-scheme/guile-1.4
+ media-libs/freetype
+ x11-libs/libXext
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8"; then
+ if ! built_with_use dev-scheme/guile deprecated; then
+ eerror "Please re-emerge dev-scheme/guile with the USE flag +deprecated"
+ die "Bad guile version"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}.patch
+}
+
+src_compile() {
+ econf $(use_with imlib imlib2 ) \
+ --enable-optimize="${CXXFLAGS}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}/TeXmacs.desktop" || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}
diff --git a/app-office/texmacs/texmacs-1.0.6.15.ebuild b/app-office/texmacs/texmacs-1.0.6.15.ebuild
index 23c36a0d2cdb..205aed815047 100644
--- a/app-office/texmacs/texmacs-1.0.6.15.ebuild
+++ b/app-office/texmacs/texmacs-1.0.6.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.6.15.ebuild,v 1.1 2008/08/19 05:43:37 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.6.15.ebuild,v 1.2 2008/08/26 06:35:49 grozin Exp $
inherit eutils
MY_P=${P/tex/TeX}-src
DESCRIPTION="Wysiwyg text processor with high-quality maths"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.texmacs.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="imlib jpeg svg netpbm spell"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
RDEPEND="virtual/latex-base
virtual/ghostscript