summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:38:56 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:38:56 +0000
commit6204bfa293bf69dde54bedbe57e1322ca4a1851f (patch)
treee9d902d7d5aab8300266ce76a291869f43e567b2 /app-pda
parentrevbump (diff)
downloadhistorical-6204bfa293bf69dde54bedbe57e1322ca4a1851f.tar.gz
historical-6204bfa293bf69dde54bedbe57e1322ca4a1851f.tar.bz2
historical-6204bfa293bf69dde54bedbe57e1322ca4a1851f.zip
adding synce-0.14 packages
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/synce-hal/ChangeLog8
-rw-r--r--app-pda/synce-hal/synce-hal-0.14.ebuild47
-rw-r--r--app-pda/synce-kpm/ChangeLog8
-rw-r--r--app-pda/synce-kpm/synce-kpm-0.14.ebuild37
-rw-r--r--app-pda/synce-librapi2/ChangeLog8
-rw-r--r--app-pda/synce-librapi2/synce-librapi2-0.14.ebuild28
-rw-r--r--app-pda/synce-librra/ChangeLog8
-rw-r--r--app-pda/synce-librra/synce-librra-0.14.ebuild31
-rw-r--r--app-pda/synce-libsynce/ChangeLog8
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.14.ebuild30
-rw-r--r--app-pda/synce-sync-engine/ChangeLog8
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild64
-rw-r--r--app-pda/synce-trayicon/ChangeLog8
-rw-r--r--app-pda/synce-trayicon/synce-trayicon-0.14.ebuild44
-rw-r--r--app-pda/synce/ChangeLog7
-rw-r--r--app-pda/synce/synce-0.14.ebuild34
16 files changed, 370 insertions, 8 deletions
diff --git a/app-pda/synce-hal/ChangeLog b/app-pda/synce-hal/ChangeLog
index 24a84907f838..32f9497901ea 100644
--- a/app-pda/synce-hal/ChangeLog
+++ b/app-pda/synce-hal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-hal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/ChangeLog,v 1.8 2009/08/05 12:53:22 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/ChangeLog,v 1.9 2009/08/06 12:29:52 mescalinum Exp $
+
+*synce-hal-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-hal-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org> -synce-hal-0.1.ebuild,
-synce-hal-0.2.ebuild:
diff --git a/app-pda/synce-hal/synce-hal-0.14.ebuild b/app-pda/synce-hal/synce-hal-0.14.ebuild
new file mode 100644
index 000000000000..e01b9d0e8dc5
--- /dev/null
+++ b/app-pda/synce-hal/synce-hal-0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/synce-hal-0.14.ebuild,v 1.1 2009/08/06 12:29:52 mescalinum Exp $
+
+inherit multilib versionator
+
+DESCRIPTION="SynCE - hal connection manager"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-apps/hal
+ >=net-libs/gnet-2.0.0
+ !app-pda/synce-dccm
+ !app-pda/synce-vdccm
+ !app-pda/synce-odccm
+ =app-pda/synce-libsynce-${synce_PV}*
+ =app-pda/synce-librapi2-${synce_PV}*
+ =app-pda/synce-librra-${synce_PV}*"
+RDEPEND="${DEPEND}
+ =app-pda/synce-sync-engine-${synce_PV}*
+ app-pda/synce-serial
+ net-misc/dhcp"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_compile() {
+ if has_version '>=sys-apps/hal-0.5.13'; then
+ HAL_ADDON_DIR="/usr/libexec/scripts"
+ else
+ HAL_ADDON_DIR="/usr/$(get_libdir)/hal/scripts"
+ fi
+ econf --with-hal-addon-dir="${HAL_ADDON_DIR}" --localstatedir="/var" || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog || die
+
+ # fix collision with app-pda/synce-serial, bug 246675
+ rm -f "${D}/usr/libexec/synce-serial-chat"
+}
diff --git a/app-pda/synce-kpm/ChangeLog b/app-pda/synce-kpm/ChangeLog
index 171d6ca0fc9a..fc1f216f26aa 100644
--- a/app-pda/synce-kpm/ChangeLog
+++ b/app-pda/synce-kpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-kpm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kpm/ChangeLog,v 1.7 2009/08/05 12:57:12 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kpm/ChangeLog,v 1.8 2009/08/06 12:35:01 mescalinum Exp $
+
+*synce-kpm-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-kpm-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
-synce-kpm-0.12.ebuild:
diff --git a/app-pda/synce-kpm/synce-kpm-0.14.ebuild b/app-pda/synce-kpm/synce-kpm-0.14.ebuild
new file mode 100644
index 000000000000..c7d671bb304d
--- /dev/null
+++ b/app-pda/synce-kpm/synce-kpm-0.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kpm/synce-kpm-0.14.ebuild,v 1.1 2009/08/06 12:35:01 mescalinum Exp $
+
+EAPI="2"
+
+inherit distutils versionator
+
+DESCRIPTION="The KDE (and Gnome) PDA Manager is an application to manage WM5/WM6 PDA devices from Linux."
+HOMEPAGE="http://www.guidodiepen.nl/category/synce/"
+LICENSE="GPL-2"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# note: some of these could possibly go... not really tested yet.
+# note: could use odccm instead of synce-hal, but would require some tweaking.
+RDEPEND="dev-python/pygobject
+ dev-python/dbus-python
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/pyxml
+ =app-pda/synce-hal-${synce_PV}*
+ =app-pda/synce-librra-${synce_PV}*
+ ~app-pda/synce-librtfcomp-1.1
+ dev-python/PyQt4[X]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+pkg_postinst() {
+ elog "If you want SynCE-KPM to manage partnerships, please emerge synce-sync-engine"
+ elog "now. You can start synce-sync-engine before or after starting SynCE-KPM."
+}
diff --git a/app-pda/synce-librapi2/ChangeLog b/app-pda/synce-librapi2/ChangeLog
index 4ed056aa0a6b..b04b75673ec7 100644
--- a/app-pda/synce-librapi2/ChangeLog
+++ b/app-pda/synce-librapi2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-librapi2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/ChangeLog,v 1.34 2009/08/05 23:30:54 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/ChangeLog,v 1.35 2009/08/06 12:25:25 mescalinum Exp $
+
+*synce-librapi2-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-librapi2-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+synce-librapi2-0.9.1.ebuild:
diff --git a/app-pda/synce-librapi2/synce-librapi2-0.14.ebuild b/app-pda/synce-librapi2/synce-librapi2-0.14.ebuild
new file mode 100644
index 000000000000..5d8e53f5bcdb
--- /dev/null
+++ b/app-pda/synce-librapi2/synce-librapi2-0.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/synce-librapi2-0.14.ebuild,v 1.1 2009/08/06 12:25:25 mescalinum Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="SynCE - RAPI communication library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ >=dev-python/pyrex-0.9.6
+ >=dev-libs/check-0.8.2
+ =app-pda/synce-libsynce-${synce_PV}*"
+RDEPEND="${DEPEND}"
+
+SRC_URI="mirror://sourceforge/synce/librapi2-${PV}.tar.gz"
+S="${WORKDIR}/librapi2-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS README README.contributing README.design TODO ChangeLog
+}
diff --git a/app-pda/synce-librra/ChangeLog b/app-pda/synce-librra/ChangeLog
index 67d7c0d00c41..9c70bae28e40 100644
--- a/app-pda/synce-librra/ChangeLog
+++ b/app-pda/synce-librra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-librra
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librra/ChangeLog,v 1.5 2009/08/05 12:37:11 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librra/ChangeLog,v 1.6 2009/08/06 12:35:51 mescalinum Exp $
+
+*synce-librra-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-librra-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
-synce-librra-0.11.1.ebuild, -synce-librra-0.12.ebuild:
diff --git a/app-pda/synce-librra/synce-librra-0.14.ebuild b/app-pda/synce-librra/synce-librra-0.14.ebuild
new file mode 100644
index 000000000000..899ef5cf4321
--- /dev/null
+++ b/app-pda/synce-librra/synce-librra-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librra/synce-librra-0.14.ebuild,v 1.1 2009/08/06 12:35:51 mescalinum Exp $
+
+inherit versionator
+
+DESCRIPTION="SynCE - RRA protocol library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ dev-python/pyrex
+ dev-libs/libmimedir
+ !app-pda/synce-rra
+ =app-pda/synce-libsynce-${synce_PV}*
+ =app-pda/synce-librapi2-${synce_PV}*"
+RDEPEND="${RDEPEND}"
+
+MY_P="librra-${PV}"
+SRC_URI="mirror://sourceforge/synce/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}
diff --git a/app-pda/synce-libsynce/ChangeLog b/app-pda/synce-libsynce/ChangeLog
index 54a8d67fc3ea..e34a775505ba 100644
--- a/app-pda/synce-libsynce/ChangeLog
+++ b/app-pda/synce-libsynce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-libsynce
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.28 2009/08/05 23:29:55 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/ChangeLog,v 1.29 2009/08/06 12:24:25 mescalinum Exp $
+
+*synce-libsynce-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-libsynce-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+synce-libsynce-0.9.1.ebuild:
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.14.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.14.ebuild
new file mode 100644
index 000000000000..bc70d8aabc3f
--- /dev/null
+++ b/app-pda/synce-libsynce/synce-libsynce-0.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.14.ebuild,v 1.1 2009/08/06 12:24:25 mescalinum Exp $
+
+inherit versionator
+
+DESCRIPTION="SynCE - common library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+DEPEND=">=dev-libs/check-0.8.3.1"
+RDEPEND="${DEPEND}"
+
+SRC_URI="mirror://sourceforge/synce/libsynce-${PV}.tar.gz"
+S="${WORKDIR}/libsynce-${PV}"
+
+src_compile() {
+ econf $(use_enable hal hal-support) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README TODO ChangeLog
+}
diff --git a/app-pda/synce-sync-engine/ChangeLog b/app-pda/synce-sync-engine/ChangeLog
index 3862e8c2a7a0..6ee09989d02e 100644
--- a/app-pda/synce-sync-engine/ChangeLog
+++ b/app-pda/synce-sync-engine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-sync-engine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.6 2009/08/05 12:50:21 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.7 2009/08/06 12:28:27 mescalinum Exp $
+
+*synce-sync-engine-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-sync-engine-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
-synce-sync-engine-0.11.1.ebuild,
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild
new file mode 100644
index 000000000000..af2f57ac21e9
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild,v 1.1 2009/08/06 12:28:27 mescalinum Exp $
+
+inherit eutils distutils versionator
+
+DESCRIPTION="SynCE - Synchronization engine"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="dev-python/pygobject
+ >=dev-python/dbus-python-0.83.0
+ >=app-pda/libopensync-plugin-python-0.22
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/pyxml
+ =app-pda/synce-librra-${synce_PV}*
+ ~app-pda/synce-librtfcomp-1.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_install() {
+ DOCS="CHANGELOG COPYING"
+
+ insinto /usr/share/${PN}/
+ doins config/syncengine.conf.xml
+
+ insinto /usr/share/dbus-1/services/
+ doins config/org.synce.SyncEngine.service
+
+ distutils_src_install
+
+ # TODO - move this to separate ebuilds.
+ if has_version '>=app-pda/libopensync-0.30'; then
+ insinto /usr/lib/opensync-1.0/python-plugins
+ newins plugins/synce-opensync-plugin-3x.py synce-opensync-plugin.py
+ else
+ insinto /usr/lib/opensync/python-plugins
+ newins plugins/synce-opensync-plugin-2x.py synce-opensync-plugin.py
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "IMPORTANT - If you are upgrading from a version earlier than 19-12-2007"
+ elog "(earlier than 0.11), please delete the contents of your ~/.synce directory"
+ elog "including the partnerships subdirectory, but KEEP config.xml. Then recreate"
+ elog "your partnerships. Please see the CHANGELOG for more info."
+ elog ""
+ elog "config.xml has been renamed to syncengine.conf.xml"
+ elog ""
+
+ elog "A default configuration file has been installed into"
+ elog "/usr/share/${PN}/syncengine.conf.xml The default search path for this file"
+ einfo "is /etc/ then ~/.synce/ You may customise it by copying it to either of"
+ einfo "those locations. Note you will have to manually migrate your old config.xml"
+}
diff --git a/app-pda/synce-trayicon/ChangeLog b/app-pda/synce-trayicon/ChangeLog
index 4c070c1e17bf..8b0a116c74be 100644
--- a/app-pda/synce-trayicon/ChangeLog
+++ b/app-pda/synce-trayicon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-trayicon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/ChangeLog,v 1.25 2009/08/05 23:57:16 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/ChangeLog,v 1.26 2009/08/06 12:31:20 mescalinum Exp $
+
+*synce-trayicon-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-trayicon-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
-synce-trayicon-0.1.ebuild, -synce-trayicon-0.7.ebuild,
diff --git a/app-pda/synce-trayicon/synce-trayicon-0.14.ebuild b/app-pda/synce-trayicon/synce-trayicon-0.14.ebuild
new file mode 100644
index 000000000000..6d926ace5658
--- /dev/null
+++ b/app-pda/synce-trayicon/synce-trayicon-0.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/synce-trayicon-0.14.ebuild,v 1.1 2009/08/06 12:31:20 mescalinum Exp $
+
+inherit eutils gnome2 versionator
+
+DESCRIPTION="SynCE - Gnome trayicon"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="sys-apps/dbus
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libgtop
+ gnome-base/libglade
+ >=gnome-base/gnome-keyring-2.20.3
+ =app-pda/synce-libsynce-${synce_PV}*
+ =app-pda/synce-librra-${synce_PV}*
+ =app-pda/synce-librapi2-${synce_PV}*
+ >=app-pda/orange-0.3.2"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-pda/synce/ChangeLog b/app-pda/synce/ChangeLog
index 8fb7ace3713e..af8f5774d901 100644
--- a/app-pda/synce/ChangeLog
+++ b/app-pda/synce/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/synce
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/ChangeLog,v 1.16 2009/08/05 12:43:52 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/ChangeLog,v 1.17 2009/08/06 12:38:56 mescalinum Exp $
+
+*synce-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org> +synce-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org> -synce-0.8.9.ebuild,
-synce-0.9.2.ebuild, -synce-0.11.1.ebuild, -synce-0.12.ebuild:
diff --git a/app-pda/synce/synce-0.14.ebuild b/app-pda/synce/synce-0.14.ebuild
new file mode 100644
index 000000000000..f7ac3ec56fc5
--- /dev/null
+++ b/app-pda/synce/synce-0.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/synce-0.14.ebuild,v 1.1 2009/08/06 12:38:56 mescalinum Exp $
+
+inherit versionator
+
+DESCRIPTION="Synchronize Windows CE devices with Linux."
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI=""
+
+synce_PV=$(get_version_component_range 1-2)
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gnome hal kde serial"
+DEPEND=""
+RDEPEND="=app-pda/synce-sync-engine-${synce_PV}*
+ hal? (
+ =app-pda/synce-hal-${synce_PV}*
+ )
+ kde? (
+ =app-pda/synce-kpm-${synce_PV}*
+ )
+ gnome? (
+ ~app-pda/synce-gvfs-0.3
+ =app-pda/synce-trayicon-${synce_PV}*
+ )
+ !app-pda/synce-gnomevfs
+ !app-pda/synce-odccm"
+
+src_compile() {
+ return
+}