summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-15 16:35:55 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-15 16:35:55 +0000
commit44a3bf8f45b919753c02ebce9ca9d1915e0dca53 (patch)
tree21973febd28e37fc7610b1c0497bb80e947e0bd7 /app-sci
parentfix bug #4744 with a note. (diff)
downloadhistorical-44a3bf8f45b919753c02ebce9ca9d1915e0dca53.tar.gz
historical-44a3bf8f45b919753c02ebce9ca9d1915e0dca53.tar.bz2
historical-44a3bf8f45b919753c02ebce9ca9d1915e0dca53.zip
Added octave unstable to portage. Closes bug #4933
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/octave/ChangeLog12
-rw-r--r--app-sci/octave/files/digest-octave-2.1.361
-rw-r--r--app-sci/octave/files/filebuf.diff41
-rw-r--r--app-sci/octave/octave-2.1.36.ebuild62
4 files changed, 115 insertions, 1 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index 0bc6a48dddde..be07a2deeda6 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.2 2002/07/13 22:56:47 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.3 2002/07/15 16:35:55 raker Exp $
+
+*octave-2.1.36 (15 Jul 2002)
+
+ 15 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ octave-2.1.36.ebuild, files/digest-octave-2.1.36, files/filebuf.diff :
+
+ Updated to latest "unstable" version. Included a patch to compile
+ properly with gcc-3.x. After fixing the problem I found RedHat's
+ patch posted to the bug report. And theirs was cleaner than mine.
+ Closes bug #4933
*octave-2.0.17 (13 Jul 2002)
diff --git a/app-sci/octave/files/digest-octave-2.1.36 b/app-sci/octave/files/digest-octave-2.1.36
new file mode 100644
index 000000000000..869e2d30fa34
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.1.36
@@ -0,0 +1 @@
+MD5 2ae3b8e954b319a6e37a41c3c5c97583 octave-2.1.36.tar.bz2 3627899
diff --git a/app-sci/octave/files/filebuf.diff b/app-sci/octave/files/filebuf.diff
new file mode 100644
index 000000000000..23a12464b348
--- /dev/null
+++ b/app-sci/octave/files/filebuf.diff
@@ -0,0 +1,41 @@
+diff -urN octave-2.1.36/src/c-file-ptr-stream.h octave-2.1.36-modified/src/c-file-ptr-stream.h
+--- octave-2.1.36/src/c-file-ptr-stream.h Thu Nov 1 23:12:00 2001
++++ octave-2.1.36-modified/src/c-file-ptr-stream.h Mon Jul 15 11:28:29 2002
+@@ -31,13 +31,23 @@
+ #include <fstream>
+ #include <cstdio>
+
++#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1)
++# include <ext/stdio_filebuf.h>
++#endif
++
+ class
+-c_file_ptr_buf : public std::filebuf
++#if defined __GNUC__ && (__GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1))
++ c_file_ptr_buf : public __gnu_cxx::stdio_filebuf<char>
++#else
++ c_file_ptr_buf : public std::filebuf
++#endif
+ {
+ public:
+
+ #if !defined (CXX_ISO_COMPLIANT_LIBRARY)
+ typedef int int_type;
++#else
++ typedef std::filebuf::int_type int_type;
+ #endif
+
+ typedef int (*close_fcn) (FILE *);
+@@ -47,7 +57,11 @@
+ c_file_ptr_buf (FILE *f_arg, close_fcn cf_arg = ::fclose)
+ :
+ #if defined __GNUC__ && __GNUC__ >= 3
+- std::filebuf (f_arg, std::ios::in | std::ios::out),
++# if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 1)
++ __gnu_cxx::stdio_filebuf<char> (f_arg, std::ios::in | std::ios::out),
++# else
++ std::filebuf (f_arg, std::ios::in | std::ios::out),
++#endif
+ #else
+ std::filebuf (f_arg ? fileno (f_arg) : -1),
+ #endif
diff --git a/app-sci/octave/octave-2.1.36.ebuild b/app-sci/octave/octave-2.1.36.ebuild
new file mode 100644
index 000000000000..0fb6707bd60d
--- /dev/null
+++ b/app-sci/octave/octave-2.1.36.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36.ebuild,v 1.1 2002/07/15 16:35:55 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
+HOMEPAGE="http://www.octave.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=dev-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2"
+RDEPEND="${DEPEND}"
+PROVIDE="dev-lang/octave"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/filebuf.diff
+
+}
+
+src_compile() {
+ # NOTE: This version actually works with gcc-3.x
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/octave \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --enable-dl \
+ --enable-shared \
+ --enable-rpath \
+ --enable-lite-kernel || die "configure failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+}