summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-10-23 16:18:43 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-10-23 16:18:43 +0000
commit97b3baa836c1bd0b3e7eaa5b67859f19b81eae8e (patch)
treec86845d4836989143c2c657c11b2b4a7cd433d6e /app-sci
parentInital ebuild (diff)
downloadhistorical-97b3baa836c1bd0b3e7eaa5b67859f19b81eae8e.tar.gz
historical-97b3baa836c1bd0b3e7eaa5b67859f19b81eae8e.tar.bz2
historical-97b3baa836c1bd0b3e7eaa5b67859f19b81eae8e.zip
added patch to compile with gcc-3.2
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/kemistry/ChangeLog5
-rw-r--r--app-sci/kemistry/files/kemistry-0.6-gcc3.2.patch55
-rw-r--r--app-sci/kemistry/kemistry-0.6.ebuild4
3 files changed, 61 insertions, 3 deletions
diff --git a/app-sci/kemistry/ChangeLog b/app-sci/kemistry/ChangeLog
index 0c034244f353..7bae9d5cff48 100644
--- a/app-sci/kemistry/ChangeLog
+++ b/app-sci/kemistry/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/kemistry
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/ChangeLog,v 1.1 2002/10/23 15:06:03 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/ChangeLog,v 1.2 2002/10/23 16:18:43 hannes Exp $
+
+ 23 Oct 2002; Hannes Mehnert <hannes@gentoo.org> kemistry-0.6.ebuild,
+ files/kemistry-0.6-gcc3.2.patch: patched source to compile with gcc-3.2
*kemistry-0.6 (23 Oct 2002)
diff --git a/app-sci/kemistry/files/kemistry-0.6-gcc3.2.patch b/app-sci/kemistry/files/kemistry-0.6-gcc3.2.patch
new file mode 100644
index 000000000000..b4ea30915f25
--- /dev/null
+++ b/app-sci/kemistry/files/kemistry-0.6-gcc3.2.patch
@@ -0,0 +1,55 @@
+--- /var/tmp/portage/kemistry-0.6/work/kemistry/kdrawchem/ioiface.cpp.orig 2002-08-20 16:22:21.000000000 +0200
++++ /var/tmp/portage/kemistry-0.6/work/kemistry/kdrawchem/ioiface.cpp 2002-10-23 17:41:48.000000000 +0200
+@@ -14,8 +14,8 @@
+ * (at your option) any later version. *
+ * *
+ ***************************************************************************/
+-#include <vector>
+-#include <map>
++#include <vector.h>
++#include <map.h>
+ #include <algorithm>
+
+ #include "ioiface.h"
+--- /var/tmp/portage/kemistry-0.6/work/kemistry/kdrawchem/kdrawchemdoc.cpp.orig 2002-08-20 16:22:21.000000000 +0200
++++ /var/tmp/portage/kemistry-0.6/work/kemistry/kdrawchem/kdrawchemdoc.cpp 2002-10-23 17:37:40.000000000 +0200
+@@ -30,6 +30,7 @@
+ #include "kdrawchem.h"
+ #include "kdrawchemview.h"
+ #include <mol.h>
++#include <fstream.h>
+
+
+ QList<KDrawChemView> *KDrawChemDoc::pViewList = 0L;
+--- /var/tmp/portage/kemistry-0.6/work/kemistry/kembabel/kembabel-openbabel.cpp.orig 2002-08-21 13:50:09.000000000 +0200
++++ /var/tmp/portage/kemistry-0.6/work/kemistry/kembabel/kembabel-openbabel.cpp 2002-10-23 17:47:47.000000000 +0200
+@@ -36,7 +36,7 @@
+ #include <qcheckbox.h>
+ #include <qradiobutton.h>
+
+-#include <fstream>
++#include <fstream.h>
+
+ #include "kembabel.h"
+
+--- /var/tmp/portage/kemistry-0.6/work/kemistry/openbabel/c3d.cpp.orig 2002-07-21 19:56:42.000000000 +0200
++++ /var/tmp/portage/kemistry-0.6/work/kemistry/openbabel/c3d.cpp 2002-10-23 17:14:48.000000000 +0200
+@@ -151,7 +151,7 @@
+ }
+
+ if (!natoms) return(false);
+- divisor = pow(10.0,exponent);
++ divisor = pow((float)10.0,exponent);
+ mol.ReserveAtoms(natoms);
+
+ ttab.SetToType("INT");
+--- /var/tmp/portage/kemistry-0.6/work/kemistry/openbabel/gaussian.cpp.orig 2002-08-01 01:20:12.000000000 +0200
++++ /var/tmp/portage/kemistry-0.6/work/kemistry/openbabel/gaussian.cpp 2002-10-23 17:17:31.000000000 +0200
+@@ -23,7 +23,7 @@
+ bool WriteGaussianCart(ostream &ofs,OBMol &mol)
+ {
+ unsigned int i;
+- unsigned int charge = 0;
++ int charge = 0;
+ unsigned int multiplicity = 0;
+ char buffer[BUFF_SIZE];
diff --git a/app-sci/kemistry/kemistry-0.6.ebuild b/app-sci/kemistry/kemistry-0.6.ebuild
index 557e4010535d..71c4d30e88a7 100644
--- a/app-sci/kemistry/kemistry-0.6.ebuild
+++ b/app-sci/kemistry/kemistry-0.6.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/kemistry-0.6.ebuild,v 1.1 2002/10/23 15:06:06 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kemistry/kemistry-0.6.ebuild,v 1.2 2002/10/23 16:18:43 hannes Exp $
+PATCHES="${FILESDIR}/${P}-gcc3.2.patch"
inherit kde-base
need-kde 3.0
IUSE=""
@@ -12,4 +13,3 @@ DESCRIPTION="Kemistry--a set of chemistry related tools for KDE."
SRC_URI="mirror://sourceforge/kemistry/${P}.tar.bz2"
HOMEPAGE="http://kemistry.sourceforge.net"
-