summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-17 23:10:45 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-02-17 23:10:45 +0000
commit6b855f13b151f05b7fa50f0e88a8b59e958dc81b (patch)
tree63772918de9f464c280565c6260c00b194c26ebd /app-shells/mpibash/mpibash-9999.ebuild
parentVersion bump, adds support for cintiq companion (bug #540204, thanks to Chand... (diff)
downloadhistorical-6b855f13b151f05b7fa50f0e88a8b59e958dc81b.tar.gz
historical-6b855f13b151f05b7fa50f0e88a8b59e958dc81b.tar.bz2
historical-6b855f13b151f05b7fa50f0e88a8b59e958dc81b.zip
added live version
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xC2000586
Diffstat (limited to 'app-shells/mpibash/mpibash-9999.ebuild')
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
new file mode 100644
index 000000000000..56644f654c2d
--- /dev/null
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-9999.ebuild,v 1.1 2015/02/17 23:10:31 ottxor Exp $
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/losalamos/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf --with-bashdir="${EPREFIX}"/usr/include/bash-plugins \
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}