summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-07-20 05:29:57 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-07-20 05:29:57 +0000
commitd8f98d9126769de95d7fade2ab99ff55c77280a5 (patch)
tree22308c673e3411e09925845ca0849622312be012 /app-shells/pdsh/pdsh-2.9.ebuild
parent(#122950) Bump, removes podchecker and adds postinst note about '-xrm' errors... (diff)
downloadhistorical-d8f98d9126769de95d7fade2ab99ff55c77280a5.tar.gz
historical-d8f98d9126769de95d7fade2ab99ff55c77280a5.tar.bz2
historical-d8f98d9126769de95d7fade2ab99ff55c77280a5.zip
(#81171) Add the parallel distributed shell (jghobrial@uh.edu).
Package-Manager: portage-2.1.1_pre3
Diffstat (limited to 'app-shells/pdsh/pdsh-2.9.ebuild')
-rw-r--r--app-shells/pdsh/pdsh-2.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/pdsh/pdsh-2.9.ebuild b/app-shells/pdsh/pdsh-2.9.ebuild
new file mode 100644
index 000000000000..4a50856e6b35
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdsh/pdsh-2.9.ebuild,v 1.1 2006/07/20 05:29:57 dberkholz Exp $
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 '-')
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A high-performance, parallel remote shell utility."
+HOMEPAGE="http://www.llnl.gov/linux/pdsh/pdsh.html"
+SRC_URI="ftp://ftp.llnl.gov/pub/linux/pdsh/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="crypt readline"
+RDEPEND="crypt? ( net-misc/openssh )
+ net-misc/netkit-rsh
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ $(use_with crypt ssh) \
+ --with-rsh \
+ $(use_with readline) \
+ --with-machines \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+}
+