summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-08-02 22:30:18 +0000
committerAron Griffis <agriffis@gentoo.org>2004-08-02 22:30:18 +0000
commit2aec83f5d4366585e75a7fb2cc671474ac48b124 (patch)
tree699a7497ae823384f38ea7bfe1aa497430655a39 /app-shells
parentelfutils does not actually seem to compile currently in a uClibc environment ... (diff)
downloadhistorical-2aec83f5d4366585e75a7fb2cc671474ac48b124.tar.gz
historical-2aec83f5d4366585e75a7fb2cc671474ac48b124.tar.bz2
historical-2aec83f5d4366585e75a7fb2cc671474ac48b124.zip
Fix bash-3.0-invisible.patch to work for more than the simple test case I used last time ;-)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/Manifest4
-rw-r--r--app-shells/bash/files/bash-3.0-invisible.patch29
3 files changed, 27 insertions, 13 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 8c83c1b00c16..c3e16f99bd78 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.45 2004/08/02 19:23:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.46 2004/08/02 22:30:18 agriffis Exp $
+
+ 02 Aug 2004; Aron Griffis <agriffis@gentoo.org>
+ files/bash-3.0-invisible.patch:
+ Fix bash-3.0-invisible.patch to work for more than the simple test case I used
+ last time ;-)
*bash-3.0-r4 (02 Aug 2004)
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index 51ca22375f9a..19fab3c3a27b 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,4 +1,4 @@
-MD5 c448f3d06446b93f6c02b01a4d9f2733 ChangeLog 9835
+MD5 b207615067efbfbebabc9231cbedbc79 ChangeLog 10017
MD5 a3a5f5e1cfbb02d35f055dae074bf237 bash-3.0-r4.ebuild 4119
MD5 9b26b6899167a29ee4e9c1ad0d39b5a1 bash-2.05b-r9.ebuild 2909
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
@@ -12,7 +12,7 @@ MD5 694b8b1e47e4743e78ee5f7515f76542 files/bash-3.0-posixtrap.patch 789
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r9 461
MD5 92f8f2d44177d92edd757366dbd261dc files/bashrc 761
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r10 461
-MD5 280727f35468e5deaadec039679ee5e8 files/bash-3.0-invisible.patch 601
+MD5 28c9d7407d5332c29dddb656a4a1f1ce files/bash-3.0-invisible.patch 705
MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0-r4 128
MD5 4a3ebcb995491c2730d156b314cbab0b files/bash-3.0-etc-inputrc.patch 1223
MD5 0392b634a7a02302d24ccc4a4b349423 files/bash-3.0-local-array.patch 275
diff --git a/app-shells/bash/files/bash-3.0-invisible.patch b/app-shells/bash/files/bash-3.0-invisible.patch
index d45cb91e5aa0..3c8a7a5a56e3 100644
--- a/app-shells/bash/files/bash-3.0-invisible.patch
+++ b/app-shells/bash/files/bash-3.0-invisible.patch
@@ -1,19 +1,20 @@
---- bash-3.0/lib/readline/display.c.agriffis 2004-08-02 09:34:14.000000000 -0400
-+++ bash-3.0/lib/readline/display.c 2004-08-02 10:48:26.256360524 -0400
-@@ -258,15 +258,16 @@
+--- bash-3.0/lib/readline/display.c 2004-05-27 22:57:51.000000000 -0400
++++ bash-3.0.agriffis/lib/readline/display.c 2004-08-02 17:43:02.000000000 -0400
+@@ -258,23 +258,21 @@
#endif
{
*r++ = *p;
- if (!ignoring)
-- rl++; /* visible length byte counter */
+ if (!ignoring)
-+ {
-+ rl++; /* visible length byte counter */
-+ if (rl >= _rl_screenwidth)
+ rl++; /* visible length byte counter */
+- else
+- ninvis++; /* invisible chars byte counter */
++ else
++ {
++ ninvis++; /* invisible chars byte counter */
++ if (rl < _rl_screenwidth)
+ invfl = ninvis;
-+ }
- else
- ninvis++; /* invisible chars byte counter */
++ }
}
- if (rl >= _rl_screenwidth)
@@ -22,3 +23,11 @@
if (ignoring == 0)
physchars++;
}
+ }
+
+- if (rl < _rl_screenwidth)
+- invfl = ninvis;
+-
+ *r = '\0';
+ if (lp)
+ *lp = rl;