summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-08 01:58:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-08 01:58:06 +0000
commit55a6c064457af09ac7685530a79a5f83baf5b8e0 (patch)
tree6e69b0898f919c6c482db8c566ea5978e1ffb0e5 /app-shells
parentno need for -L$ROOT workaround in ebuild (diff)
downloadhistorical-55a6c064457af09ac7685530a79a5f83baf5b8e0.tar.gz
historical-55a6c064457af09ac7685530a79a5f83baf5b8e0.tar.bz2
historical-55a6c064457af09ac7685530a79a5f83baf5b8e0.zip
make sure sash respects $LDFLAGS
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/Manifest8
-rw-r--r--app-shells/sash/sash-3.7.ebuild12
2 files changed, 9 insertions, 11 deletions
diff --git a/app-shells/sash/Manifest b/app-shells/sash/Manifest
index cfaf358fe080..976e71c1137c 100644
--- a/app-shells/sash/Manifest
+++ b/app-shells/sash/Manifest
@@ -3,7 +3,7 @@ Hash: SHA1
MD5 e3730768e4af7333d98268a0b2ed5869 ChangeLog 3789
MD5 3b21afef4759a8477260dc345b99525c sash-3.6.ebuild 1079
-MD5 f19c46c9903d1a421070208d8fb47538 sash-3.7.ebuild 1279
+MD5 8b0650eca70756a31c02f7c5d38fad69 sash-3.7.ebuild 1129
MD5 d38ab7c3e9697a320856b2a1727d9be8 files/sash-3.6-2.6-includes.patch 291
MD5 c0a4b54f51097cb6d1e76b0f0df2d938 files/digest-sash-3.6 59
MD5 570237f86f81b58c68835104a03da8dc files/sash-3.4-gentoo.diff 7087
@@ -15,7 +15,7 @@ MD5 0fa262804299a7ba80c5266f578722eb files/sash-3.7-builtin.patch 465
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBtlRNroRuSHgZdywRApbFAJwMZMJwvZKnxpE6upv/5V515QQq5ACffqO0
-N20JIpsKPe0jhBYyhnzge6A=
-=g97v
+iD8DBQFBtl+4roRuSHgZdywRAsvbAJ9Z4FIeFTXGOM5WaIKntMsDjJfF0wCfcTIH
+q2PJOsa6jvm58Ic7sVFgI6c=
+=LZY8
-----END PGP SIGNATURE-----
diff --git a/app-shells/sash/sash-3.7.ebuild b/app-shells/sash/sash-3.7.ebuild
index 504c21ca7b30..2549cbdde7fd 100644
--- a/app-shells/sash/sash-3.7.ebuild
+++ b/app-shells/sash/sash-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.17 2004/12/08 01:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.18 2004/12/08 01:58:06 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,12 +26,10 @@ src_unpack() {
epatch ${FILESDIR}/sash-3.7-builtin.patch
use readline && epatch ${FILESDIR}/sash-3.6-readline.patch
- # this indicates broken header files but don't know what to do
- # about it yet. (03 Mar 2004 agriffis)
- use ia64 && append-flags -Du64=__u64 -Du32=__u32 -Ds64=__s64 -Ds32=__s32
-
- # use our CFLAGS in the Makefile
- sed -e "s:-O3:${CFLAGS}:" -i Makefile
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/^LDFLAGS /s:$:${LDFLAGS}:" \
+ Makefile || die "sed failed"
}
src_compile() {