summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-01-22 05:30:44 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-01-22 05:30:44 +0000
commit2c2002400e5bc528476aac3b3a33f983681ac26f (patch)
tree83fba5deeed503c6900367dc964fbd703102532d /app-text/jing
parentVersion bump (bug #118576). (diff)
downloadhistorical-2c2002400e5bc528476aac3b3a33f983681ac26f.tar.gz
historical-2c2002400e5bc528476aac3b3a33f983681ac26f.tar.bz2
historical-2c2002400e5bc528476aac3b3a33f983681ac26f.zip
Added patch to fix compilation with xerces-2.7 to fix bug #119366.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-text/jing')
-rw-r--r--app-text/jing/ChangeLog8
-rw-r--r--app-text/jing/Manifest19
-rw-r--r--app-text/jing/files/jing-20030619-xerces.patch33
-rw-r--r--app-text/jing/jing-20030619-r1.ebuild5
4 files changed, 52 insertions, 13 deletions
diff --git a/app-text/jing/ChangeLog b/app-text/jing/ChangeLog
index b31ceff173a9..241b3cd6c820 100644
--- a/app-text/jing/ChangeLog
+++ b/app-text/jing/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/jing
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.13 2005/07/12 18:11:17 axxo Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/ChangeLog,v 1.14 2006/01/22 05:30:44 nichoj Exp $
+
+ 22 Jan 2006; Joshua Nichols <nichoj@gentoo.org>
+ +files/jing-20030619-xerces.patch, jing-20030619-r1.ebuild:
+ Added patch to fix compilation with xerces-2.7 to fix bug #119366.
12 Jul 2005; Thomas Matthijs <axxo@gentoo.org> jing-20030619-r1.ebuild:
Style/Dep fixes
diff --git a/app-text/jing/Manifest b/app-text/jing/Manifest
index b8e012bd67db..e2eae3a70b8d 100644
--- a/app-text/jing/Manifest
+++ b/app-text/jing/Manifest
@@ -1,17 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 162e3d4c99303c8b2389bfaa53ad5b2a ChangeLog 1782
-MD5 7e154f1bbc76c938f7177842559dc38d jing-20030619-r1.ebuild 1431
-MD5 79a5dd1b805e5bca495aec6d6a73826b metadata.xml 176
-MD5 a2004d054506b2ec4e8add35ec84dc44 files/digest-jing-20030619-r1 63
+MD5 650f7673064f96e185224d6cd1b9ad1f ChangeLog 1966
+MD5 4e01494f4274dfe8fbed0b4982405537 files/build-patch.diff 1484
MD5 9ca0559020eae581281496f04c53dd7b files/build.xml 710
+MD5 a2004d054506b2ec4e8add35ec84dc44 files/digest-jing-20030619-r1 63
+MD5 16d1fac29c56d57e0eee5aecefee4fcf files/jing-20030619-xerces.patch 1393
MD5 60267d864fc6a05822d8b732ff12e8dd files/manifest.mf 136
-MD5 4e01494f4274dfe8fbed0b4982405537 files/build-patch.diff 1484
+MD5 e1836574ad24fe4864d2d3f14b588803 jing-20030619-r1.ebuild 1471
+MD5 79a5dd1b805e5bca495aec6d6a73826b metadata.xml 176
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC1Aff/rLF9B432nYRAtvSAJ4t1GOKZOwOgSlPyTN6zLr0Tqg6qACfSEFx
-0x/Xd+u+l5CBXYK8yaIotBE=
-=T4Zd
+iD8DBQFD0xW/ndWRXhKOboURAhsWAKDTpOmxdJRrw1EnuD/qFepK/ryWCACdHhiE
+afjXxWIOwmk8CkDJaPlV0C0=
+=47Z+
-----END PGP SIGNATURE-----
diff --git a/app-text/jing/files/jing-20030619-xerces.patch b/app-text/jing/files/jing-20030619-xerces.patch
new file mode 100644
index 000000000000..5873822b4ccb
--- /dev/null
+++ b/app-text/jing/files/jing-20030619-xerces.patch
@@ -0,0 +1,33 @@
+Only in jing-20030619: META-INF
+diff -ru jing-20030619-orig/src/com/thaiopensource/relaxng/util/JingTask.java jing-20030619/src/com/thaiopensource/relaxng/util/JingTask.java
+--- jing-20030619-orig/src/com/thaiopensource/relaxng/util/JingTask.java 2003-05-30 20:54:52.000000000 -0400
++++ jing-20030619/src/com/thaiopensource/relaxng/util/JingTask.java 2006-01-22 00:14:34.000000000 -0500
+@@ -178,4 +178,11 @@
+ filesets.addElement(set);
+ }
+
++ public String getXMLVersion() {
++ throw new UnsupportedOperationException();
++ }
++
++ public int getCharacterOffset() {
++ throw new UnsupportedOperationException();
++ }
+ }
+diff -ru jing-20030619-orig/src/com/thaiopensource/validate/xerces/ValidatorImpl.java jing-20030619/src/com/thaiopensource/validate/xerces/ValidatorImpl.java
+--- jing-20030619-orig/src/com/thaiopensource/validate/xerces/ValidatorImpl.java 2003-06-19 13:57:22.000000000 -0400
++++ jing-20030619/src/com/thaiopensource/validate/xerces/ValidatorImpl.java 2006-01-22 00:15:10.000000000 -0500
+@@ -330,4 +330,12 @@
+ throw (RuntimeException)nested;
+ return new SAXException(nested);
+ }
++
++ public String getXMLVersion() {
++ throw new UnsupportedOperationException();
++ }
++ public int getCharacterOffset() {
++ throw new UnsupportedOperationException();
++ }
++
+ }
+Only in jing-20030619/src/com/thaiopensource/validate/xerces: .ValidatorImpl.java.swp
diff --git a/app-text/jing/jing-20030619-r1.ebuild b/app-text/jing/jing-20030619-r1.ebuild
index 7e0308dab30e..e62c4d7365d5 100644
--- a/app-text/jing/jing-20030619-r1.ebuild
+++ b/app-text/jing/jing-20030619-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20030619-r1.ebuild,v 1.6 2005/07/12 18:11:17 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20030619-r1.ebuild,v 1.7 2006/01/22 05:30:44 nichoj Exp $
inherit java-pkg eutils
@@ -28,6 +28,7 @@ src_unpack() {
unzip -qq -d src/ src.zip || die "failed to unzip"
cd src/
epatch ${FILESDIR}/build-patch.diff
+ epatch ${FILESDIR}/${P}-xerces.patch
cd ../bin/
rm -f *.jar