summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-11 21:51:33 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-11 21:51:33 +0000
commit70b4651178e6f33a151269471d8e1fa072fc9d6f (patch)
treefad7133a17ede4ad9c3bb4119f8f044e5a646c48 /app-text
parentStable on ppc64; bug #114428 (diff)
downloadhistorical-70b4651178e6f33a151269471d8e1fa072fc9d6f.tar.gz
historical-70b4651178e6f33a151269471d8e1fa072fc9d6f.tar.bz2
historical-70b4651178e6f33a151269471d8e1fa072fc9d6f.zip
Add patch to fix compilation with gcc-4.1; Thanks to Stefan Vunckx <stefan.vunckx AT skynet DOT be>; bug #113896
Package-Manager: portage-2.0.53
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwpd/ChangeLog7
-rw-r--r--app-text/libwpd/Manifest10
-rw-r--r--app-text/libwpd/files/libwpd-0.8.2-gcc41.patch79
-rw-r--r--app-text/libwpd/libwpd-0.8.2.ebuild8
4 files changed, 102 insertions, 2 deletions
diff --git a/app-text/libwpd/ChangeLog b/app-text/libwpd/ChangeLog
index 040dd958cab8..9e5e04bde371 100644
--- a/app-text/libwpd/ChangeLog
+++ b/app-text/libwpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwpd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.20 2005/12/04 19:45:50 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.21 2005/12/11 21:51:32 halcy0n Exp $
+
+ 11 Dec 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/libwpd-0.8.2-gcc41.patch, libwpd-0.8.2.ebuild:
+ Add patch to fix compilation with gcc-4.1; Thanks to Stefan Vunckx
+ <stefan.vunckx AT skynet DOT be>; bug #113896
04 Doc 2005; Tom Gall <tgall@gentoo.org> libwpd-0.8.2.ebuild:
stable on ppc64
diff --git a/app-text/libwpd/Manifest b/app-text/libwpd/Manifest
index 308cf2b16d5b..fab8a0017338 100644
--- a/app-text/libwpd/Manifest
+++ b/app-text/libwpd/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 971e6d4433c1f17708d6fb696c74264b ChangeLog 2503
MD5 15bfdcb6f86c239b6a90414b4dfeed49 files/digest-libwpd-0.7.1 64
MD5 95c86ec8c33955b7d8d5e243ea27dea0 files/digest-libwpd-0.7.2 64
@@ -7,3 +10,10 @@ MD5 ae8843192d7ae9b6b06801f3b3247392 libwpd-0.7.1.ebuild 654
MD5 71a2cbd885492d38000f7a0226e62284 libwpd-0.7.2.ebuild 661
MD5 f6971abd6d135afee1325894ed3d0f8a libwpd-0.8.2.ebuild 834
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDnJ+PCRZPokWLroQRAqNPAJwIksTfkRh8PzTTxjXkBPMsJ7FPWgCgmuUQ
+RTOJ0a+DEu03JWyPgyY2j6Q=
+=KSMy
+-----END PGP SIGNATURE-----
diff --git a/app-text/libwpd/files/libwpd-0.8.2-gcc41.patch b/app-text/libwpd/files/libwpd-0.8.2-gcc41.patch
new file mode 100644
index 000000000000..08fca1bdf312
--- /dev/null
+++ b/app-text/libwpd/files/libwpd-0.8.2-gcc41.patch
@@ -0,0 +1,79 @@
+--- libwpd-0.8.1-orig/src/lib/WP3FixedLengthGroup.h.old 2005-11-23 00:39:46.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP3FixedLengthGroup.h 2005-11-23 00:40:07.000000000 +0100
+@@ -30,8 +30,8 @@
+ class WP3FixedLengthGroup : public WP3Part
+ {
+ public:
+- WP3FixedLengthGroup::WP3FixedLengthGroup(int groupID);
+- static WP3FixedLengthGroup * WP3FixedLengthGroup::constructFixedLengthGroup(WPXInputStream *input, uint8_t groupID);
++ WP3FixedLengthGroup(int groupID);
++ static WP3FixedLengthGroup * constructFixedLengthGroup(WPXInputStream *input, uint8_t groupID);
+
+ const uint8_t getGroup() const { return m_group; }
+
+--- libwpd-0.8.1-orig/src/lib/WP3SingleByteFunction.h.old 2005-11-23 00:41:25.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP3SingleByteFunction.h 2005-11-23 00:41:41.000000000 +0100
+@@ -32,7 +32,7 @@
+ class WP3SingleByteFunction : public WP3Part
+ {
+ public:
+- static WP3SingleByteFunction * WP3SingleByteFunction::constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
++ static WP3SingleByteFunction * constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
+ };
+
+ /*class WP3SpaceFunction : public WP3SingleByteFunction
+--- libwpd-0.8.1-orig/src/lib/WP5SingleByteFunction.h.old 2005-11-23 00:43:46.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP5SingleByteFunction.h 2005-11-23 00:44:03.000000000 +0100
+@@ -32,7 +32,7 @@
+ class WP5SingleByteFunction : public WP5Part
+ {
+ public:
+- static WP5SingleByteFunction * WP5SingleByteFunction::constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
++ static WP5SingleByteFunction * constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
+ };
+
+ class WP5EOLFunction : public WP5SingleByteFunction
+--- libwpd-0.8.1-orig/src/lib/WP6FixedLengthGroup.h.old 2005-11-23 00:44:34.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP6FixedLengthGroup.h 2005-11-23 00:44:52.000000000 +0100
+@@ -32,7 +32,7 @@
+ {
+ public:
+ WP6FixedLengthGroup(uint8_t groupID);
+- static WP6FixedLengthGroup * WP6FixedLengthGroup::constructFixedLengthGroup(WPXInputStream *input, uint8_t groupID);
++ static WP6FixedLengthGroup * constructFixedLengthGroup(WPXInputStream *input, uint8_t groupID);
+
+ const uint8_t getGroup() const { return m_group; }
+
+--- libwpd-0.8.1-orig/src/lib/WP6SingleByteFunction.h.old 2005-11-23 00:46:34.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP6SingleByteFunction.h 2005-11-23 00:46:47.000000000 +0100
+@@ -31,7 +31,7 @@
+ class WP6SingleByteFunction : public WP6Part
+ {
+ public:
+- static WP6SingleByteFunction * WP6SingleByteFunction::constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
++ static WP6SingleByteFunction * constructSingleByteFunction(WPXInputStream *input, uint8_t groupID);
+ };
+
+ class WP6SpaceFunction : public WP6SingleByteFunction
+--- libwpd-0.8.1-orig/src/lib/WP6VariableLengthGroup.h.old 2005-11-23 00:45:14.000000000 +0100
++++ libwpd-0.8.1/src/lib/WP6VariableLengthGroup.h 2005-11-23 00:45:29.000000000 +0100
+@@ -41,7 +41,7 @@
+ WP6VariableLengthGroup(); // WP6VariableLengthGroup should _never_ be constructed, only its inherited classes
+ virtual ~WP6VariableLengthGroup();
+
+- static WP6VariableLengthGroup * WP6VariableLengthGroup::constructVariableLengthGroup(WPXInputStream *input, uint8_t groupID);
++ static WP6VariableLengthGroup * constructVariableLengthGroup(WPXInputStream *input, uint8_t groupID);
+
+ protected:
+ void _read(WPXInputStream *input);
+--- libwpd-0.8.1-orig/src/lib/WPXHLListener.h.old 2005-11-23 00:40:32.000000000 +0100
++++ libwpd-0.8.1/src/lib/WPXHLListener.h 2005-11-23 00:40:48.000000000 +0100
+@@ -157,7 +157,7 @@
+ {
+ public:
+ WPXHLListener(std::vector<WPXPageSpan *> *pageList, WPXHLListenerImpl *listenerImpl);
+- WPXHLListener::~WPXHLListener();
++ ~WPXHLListener();
+
+ void startDocument();
+ void handleSubDocument(uint16_t textPID, const bool isHeaderFooter, WPXTableList tableList, int nextTableIndice);
diff --git a/app-text/libwpd/libwpd-0.8.2.ebuild b/app-text/libwpd/libwpd-0.8.2.ebuild
index bf4b9ac9b696..8700f2271082 100644
--- a/app-text/libwpd/libwpd-0.8.2.ebuild
+++ b/app-text/libwpd/libwpd-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.8.2.ebuild,v 1.6 2005/12/04 19:45:50 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.8.2.ebuild,v 1.7 2005/12/11 21:51:32 halcy0n Exp $
inherit eutils
@@ -20,6 +20,12 @@ RDEPEND=">=dev-libs/glib-2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
econf $(use_with doc docs) || die
emake || die