summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-07-31 19:27:34 +0000
committerAron Griffis <agriffis@gentoo.org>2003-07-31 19:27:34 +0000
commit464444c7f60a9172150649e413837a49dcdf2ff3 (patch)
treee416688c0d9bc1d1d1d49a9e7779045c113bc85a /app-vim
parentfix bug 25639: use exuberant-ctags (diff)
downloadhistorical-464444c7f60a9172150649e413837a49dcdf2ff3.tar.gz
historical-464444c7f60a9172150649e413837a49dcdf2ff3.tar.bz2
historical-464444c7f60a9172150649e413837a49dcdf2ff3.zip
fix bug 25639: use exuberant-ctags
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/taglist/Manifest6
-rw-r--r--app-vim/taglist/files/digest-taglist-2.6-r11
-rw-r--r--app-vim/taglist/files/taglist-2.6-exuberant.patch11
-rw-r--r--app-vim/taglist/taglist-2.6-r1.ebuild17
4 files changed, 32 insertions, 3 deletions
diff --git a/app-vim/taglist/Manifest b/app-vim/taglist/Manifest
index 94dedb35cabf..c38345d0da71 100644
--- a/app-vim/taglist/Manifest
+++ b/app-vim/taglist/Manifest
@@ -1,7 +1,7 @@
-MD5 4d04ab3ca2c9d1b8cfb7fa53739f5113 ChangeLog 564
+MD5 1364639d23f74547b0fa05cb6fc6ab83 ChangeLog 769
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 9476736bd0371c40297bb626edfbc9cb taglist-2.6.ebuild 442
-MD5 a99adfd5b1c8c0647f0edc781439c14e taglist-2.6-r1.ebuild 553
+MD5 330a3bf83b52115adcb6d664fbf7a18f taglist-2.6-r1.ebuild 556
MD5 8d964b3af8b95753a6d3cf9f8a493818 files/digest-taglist-2.6 63
-MD5 3327d9590fa865d59c922c8ffd3c371b files/taglist-2.6-exuberant.patch 335
+MD5 c7f319a44a948c29f40f341c69126fd9 files/taglist-2.6-exuberant.patch 349
MD5 8d964b3af8b95753a6d3cf9f8a493818 files/digest-taglist-2.6-r1 63
diff --git a/app-vim/taglist/files/digest-taglist-2.6-r1 b/app-vim/taglist/files/digest-taglist-2.6-r1
new file mode 100644
index 000000000000..06278ed9df18
--- /dev/null
+++ b/app-vim/taglist/files/digest-taglist-2.6-r1
@@ -0,0 +1 @@
+MD5 debf24a3590f0c3f5d44bdd9f3d3737e taglist-2.6.tar.bz2 14752
diff --git a/app-vim/taglist/files/taglist-2.6-exuberant.patch b/app-vim/taglist/files/taglist-2.6-exuberant.patch
new file mode 100644
index 000000000000..20f827c394a6
--- /dev/null
+++ b/app-vim/taglist/files/taglist-2.6-exuberant.patch
@@ -0,0 +1,11 @@
+--- plugin/taglist.vim.old 2003-07-31 09:58:41.000000000 -0400
++++ plugin/taglist.vim 2003-07-31 15:15:27.000000000 -0400
+@@ -350,7 +350,7 @@
+
+ " Location of the exuberant ctags tool
+ if !exists('Tlist_Ctags_Cmd')
+- let Tlist_Ctags_Cmd = 'ctags'
++ let Tlist_Ctags_Cmd = 'exuberant-ctags'
+ endif
+
+ " Tag listing sort type - 'name' or 'order'
diff --git a/app-vim/taglist/taglist-2.6-r1.ebuild b/app-vim/taglist/taglist-2.6-r1.ebuild
new file mode 100644
index 000000000000..499c11d0e243
--- /dev/null
+++ b/app-vim/taglist/taglist-2.6-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/taglist-2.6-r1.ebuild,v 1.1 2003/07/31 19:27:28 agriffis Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=273"
+LICENSE="vim"
+KEYWORDS="~x86 ~alpha"
+RDEPEND="${RDEPEND} dev-util/ctags"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/taglist-2.6-exuberant.patch || die "epatch failed"
+}