summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-30 15:52:33 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-30 15:52:33 +0000
commit18b4a7c97f261c514c35e639fe4742274a4add70 (patch)
tree41ed6fd57c9abf96bf8ad5254b2996f31e343018 /dev-cpp/gtest
parentkeyword ~x86-fbsd (diff)
downloadhistorical-18b4a7c97f261c514c35e639fe4742274a4add70.tar.gz
historical-18b4a7c97f261c514c35e639fe4742274a4add70.tar.bz2
historical-18b4a7c97f261c514c35e639fe4742274a4add70.zip
Version bump.
Package-Manager: portage-2.2.0_alpha95/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/ChangeLog9
-rw-r--r--dev-cpp/gtest/gtest-1.6.0.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-cpp/gtest/ChangeLog b/dev-cpp/gtest/ChangeLog
index b8be0cef9a82..1a8b3939f406 100644
--- a/dev-cpp/gtest/ChangeLog
+++ b/dev-cpp/gtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gtest
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/ChangeLog,v 1.2 2011/12/09 12:29:08 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/ChangeLog,v 1.3 2012/03/30 15:52:33 vapier Exp $
+
+*gtest-1.6.0 (30 Mar 2012)
+
+ 30 Mar 2012; Mike Frysinger <vapier@gentoo.org> +gtest-1.6.0.ebuild:
+ Version bump.
09 Dec 2011; Naohiro Aota <naota@gentoo.org> gtest-1.5.0.ebuild:
Add ~x86-fbsd
diff --git a/dev-cpp/gtest/gtest-1.6.0.ebuild b/dev-cpp/gtest/gtest-1.6.0.ebuild
new file mode 100644
index 000000000000..9511cce9fc26
--- /dev/null
+++ b/dev-cpp/gtest/gtest-1.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/gtest-1.6.0.ebuild,v 1.1 2012/03/30 15:52:33 vapier Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Google C++ Testing Framework"
+HOMEPAGE="http://code.google.com/p/googletest/"
+SRC_URI="http://googletest.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ppc-macos"
+IUSE="examples threads static-libs"
+
+pkg_setup() {
+ python_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die
+ sed -i -r \
+ -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
+ Makefile.in
+
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads)
+}
+
+src_test() {
+ # explicitly use parallel make
+ emake check || die
+}
+
+src_install() {
+ default
+ dobin scripts/gtest-config
+
+ if ! use static-libs ; then
+ rm "${ED}"/usr/lib*/*.la || die
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins samples/*.{cc,h}
+ fi
+}