summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:44:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:44:39 +0000
commit2d6077e8863ecf010b7b6ab2bfebcfe8b0cede19 (patch)
tree27bdbe84bd3720f8d8d5ef69e75bb8fc4992d593 /dev-db/libdbi-drivers
parentRemove old. (diff)
downloadhistorical-2d6077e8863ecf010b7b6ab2bfebcfe8b0cede19.tar.gz
historical-2d6077e8863ecf010b7b6ab2bfebcfe8b0cede19.tar.bz2
historical-2d6077e8863ecf010b7b6ab2bfebcfe8b0cede19.zip
Conditionalize static lib creation and prune the .la file.
Package-Manager: portage-2.2.0_alpha125/cvs/Linux x86_64
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog6
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
index 1e7210586ac8..ef88e47e0b68 100644
--- a/dev-db/libdbi-drivers/ChangeLog
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libdbi-drivers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.52 2012/09/13 18:41:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.53 2012/09/13 18:43:48 scarabeus Exp $
+
+ 13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ libdbi-drivers-0.8.3-r2.ebuild:
+ Conditionalize static lib creation and prune the .la file.
13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org>
-files/libdbi-drivers-0.8.1-oci8.diff, -libdbi-drivers-0.8.1-r1.ebuild,
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
index 526303032482..77199fd5dfc6 100644
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.2 2012/09/13 18:41:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.3 2012/09/13 18:43:48 scarabeus Exp $
EAPI=4
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
LICENSE="LGPL-2.1"
-IUSE="bindist doc firebird mysql oci8 postgres +sqlite"
+IUSE="bindist doc firebird mysql oci8 postgres +sqlite static-libs"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
SLOT=0
@@ -65,6 +65,7 @@ src_configure() {
econf \
$(use_enable doc docs) \
+ $(use_enable static-libs static) \
${myconf}
}
@@ -77,3 +78,9 @@ src_test() {
einfo "Running interactive tests"
emake check
}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}