summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 16:09:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 16:09:35 +0000
commit23ea6c274ceff2698622fc43fa96d5242ae2c9ed (patch)
treef91b7e948654ce88aad0a8ba499c4e5bd4b786a4 /dev-db/pygresql/pygresql-4.0.ebuild
parentUnmasking qt-creator (diff)
downloadhistorical-23ea6c274ceff2698622fc43fa96d5242ae2c9ed.tar.gz
historical-23ea6c274ceff2698622fc43fa96d5242ae2c9ed.tar.bz2
historical-23ea6c274ceff2698622fc43fa96d5242ae2c9ed.zip
Bump to 4.0. Fixes #256329
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'dev-db/pygresql/pygresql-4.0.ebuild')
-rw-r--r--dev-db/pygresql/pygresql-4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/pygresql/pygresql-4.0.ebuild b/dev-db/pygresql/pygresql-4.0.ebuild
new file mode 100644
index 000000000000..d65f374b5a1e
--- /dev/null
+++ b/dev-db/pygresql/pygresql-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-4.0.ebuild,v 1.1 2009/04/23 16:09:35 patrick Exp $
+
+inherit eutils distutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
+LICENSE="as-is"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=virtual/postgresql-base-7.4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/*.txt
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ dohtml docs/*.{html,css}
+ fi
+}