summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron Swenson <titanofold@gentoo.org>2013-01-12 18:59:35 +0000
committerAaron Swenson <titanofold@gentoo.org>2013-01-12 18:59:35 +0000
commit2a74307b2cc86e73f3b8807a2a5be222e53e8fc6 (patch)
tree968debf59530b64c5f4e154d37a464d3abd7795c /dev-db
parentapp-office/texmaker: Add fix for clang, #449376 (diff)
downloadhistorical-2a74307b2cc86e73f3b8807a2a5be222e53e8fc6.tar.gz
historical-2a74307b2cc86e73f3b8807a2a5be222e53e8fc6.tar.bz2
historical-2a74307b2cc86e73f3b8807a2a5be222e53e8fc6.zip
Fixes bug 444214
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0xD1BBFDA0
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql-docs/ChangeLog16
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild57
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.4.15-r1.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.0.11-r1.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.1.7-r1.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.2.2-r1.ebuild59
6 files changed, 283 insertions, 2 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 27eeaf142d7f..e7127194d61b 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-db/postgresql-docs
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.184 2012/12/10 06:02:52 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.185 2013/01/12 18:59:35 titanofold Exp $
+
+*postgresql-docs-9.2.2-r1 (12 Jan 2013)
+*postgresql-docs-9.1.7-r1 (12 Jan 2013)
+*postgresql-docs-9.0.11-r1 (12 Jan 2013)
+*postgresql-docs-8.4.15-r1 (12 Jan 2013)
+*postgresql-docs-8.3.22-r1 (12 Jan 2013)
+
+ 12 Jan 2013; Aaron W. Swenson <titanofold@gentoo.org>
+ +postgresql-docs-8.3.22-r1.ebuild, +postgresql-docs-8.4.15-r1.ebuild,
+ +postgresql-docs-9.0.11-r1.ebuild, +postgresql-docs-9.1.7-r1.ebuild,
+ +postgresql-docs-9.2.2-r1.ebuild:
+ Fixes bug 444214
*postgresql-docs-9.1.7 (10 Dec 2012)
*postgresql-docs-8.3.22 (10 Dec 2012)
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild
new file mode 100644
index 000000000000..ec5907fc928a
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ dodir ${mypath}/html
+ tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
+
+ insinto ${mypath}/FAQ_html
+ doins src/FAQ/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ insinto ${mypath}/TODO.detail
+ doins TODO.detail/*
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.4.15-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.4.15-r1.ebuild
new file mode 100644
index 000000000000..dd14003c5124
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.15-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.4.15-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ dodir ${mypath}/html
+ tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.0.11-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.0.11-r1.ebuild
new file mode 100644
index 000000000000..40987b13ddc7
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.0.11-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.0.11-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.1.7-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.1.7-r1.ebuild
new file mode 100644
index 000000000000..a0707a9a5a6e
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.1.7-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.1.7-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+SLOT="$(get_version_component_range 1-2)"
+S="${WORKDIR}/postgresql-${PV}"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.2.2-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.2.2-r1.ebuild
new file mode 100644
index 000000000000..681087b8016e
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.2.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.2.2-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}