summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-06-10 20:08:32 +0000
committerDon Seiler <rizzo@gentoo.org>2004-06-10 20:08:32 +0000
commitb61041ecbfabdffe8a68faf8a8aaa9f439273103 (patch)
tree79648ab33ad86595b31bae29379f672eb4a4bd3c /dev-db
parentnew version on cpan (diff)
downloadhistorical-b61041ecbfabdffe8a68faf8a8aaa9f439273103.tar.gz
historical-b61041ecbfabdffe8a68faf8a8aaa9f439273103.tar.bz2
historical-b61041ecbfabdffe8a68faf8a8aaa9f439273103.zip
Fixing USE usage
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tora/ChangeLog5
-rw-r--r--dev-db/tora/Manifest4
-rw-r--r--dev-db/tora/tora-1.3.13.ebuild22
3 files changed, 17 insertions, 14 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 1d77a365de43..28cf28c2f832 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.23 2004/04/20 15:38:26 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.24 2004/06/10 20:08:32 rizzo Exp $
+
+ 10 Jun 2004; Don Seiler <rizzo@gentoo.org> tora-1.3.13.ebuild:
+ Fixing USE usage, thanks to agriffis and vapier for the science.
20 Apr 2004; Don Seiler <rizzo@gentoo.org>; tora-1.3.13.ebuild:
Adding debug support
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
index 2809e0d8648d..3c88cfa2d58a 100644
--- a/dev-db/tora/Manifest
+++ b/dev-db/tora/Manifest
@@ -1,4 +1,4 @@
-MD5 b8a6e5863c81e8b75b031ddab3c8c0a2 tora-1.3.13.ebuild 1551
-MD5 0776c924a0001a47d40ce66a9d97f04d ChangeLog 3690
+MD5 50dec218f22d91164a0c6ba6efd0ddbe ChangeLog 3822
MD5 bda8803c4adc9cf0b308b71157891f05 metadata.xml 536
+MD5 1dd8b10e9ce7c452d1431a8adfa8b356 tora-1.3.13.ebuild 1558
MD5 6e56617a37ef8382d8eda0609b63ea02 files/digest-tora-1.3.13 70
diff --git a/dev-db/tora/tora-1.3.13.ebuild b/dev-db/tora/tora-1.3.13.ebuild
index 025c35cf2cfb..849bf0637e1a 100644
--- a/dev-db/tora/tora-1.3.13.ebuild
+++ b/dev-db/tora/tora-1.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.13.ebuild,v 1.5 2004/04/20 15:38:26 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.13.ebuild,v 1.6 2004/06/10 20:08:32 rizzo Exp $
use debug && inherit debug
@@ -18,16 +18,16 @@ DEPEND=">=x11-libs/qt-3.0.0
kde? ( >=kde-base/kdelibs-3.1 )"
pkg_setup() {
- if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
- ewarn "ORACLE_HOME variable is not set."
- ewarn
- ewarn "You must install Oracle >= 8i client for Linux in"
- ewarn "order to compile TOra with Oracle support."
- ewarn
- ewarn "Otherwise specify -oci8 in your USE variable."
- ewarn
- ewarn "You can download the Oracle software from"
- ewarn "http://otn.oracle.com/software/content.html"
+ if use oci8 && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oci8 in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
die
fi
}