summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-18 19:47:11 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-18 19:47:11 +0000
commitc7965fb4876bb2f956c103d08662c6f412c2a70b (patch)
tree80dc6925a22013acc3f1312980c692c791c098c4 /dev-db
parent*** empty log message *** (diff)
downloadhistorical-c7965fb4876bb2f956c103d08662c6f412c2a70b.tar.gz
historical-c7965fb4876bb2f956c103d08662c6f412c2a70b.tar.bz2
historical-c7965fb4876bb2f956c103d08662c6f412c2a70b.zip
*** empty log message ***
Diffstat (limited to 'dev-db')
-rwxr-xr-xdev-db/mysql/files/mysql2
-rw-r--r--dev-db/mysql/mysql-3.23.31.ebuild112
2 files changed, 113 insertions, 1 deletions
diff --git a/dev-db/mysql/files/mysql b/dev-db/mysql/files/mysql
index 4aef25c9a38c..f4c8c9ff6406 100755
--- a/dev-db/mysql/files/mysql
+++ b/dev-db/mysql/files/mysql
@@ -22,7 +22,7 @@ PATH=/sbin:/usr/sbin:/bin:/usr/bin
basedir=/usr
bindir=/usr/bin
datadir=/var/mysql
-pid_file=/var/mysql/mysqld.pid
+pid_file=/var/run/mysqld.pid
mysql_daemon_user=root # Run mysqld as this user.
export PATH
diff --git a/dev-db/mysql/mysql-3.23.31.ebuild b/dev-db/mysql/mysql-3.23.31.ebuild
new file mode 100644
index 000000000000..6116be86f963
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.31.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.31.ebuild,v 1.1 2001/01/18 19:47:11 achim Exp $
+
+P=${PN}-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The MySQL Database"
+SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${A}
+ http://www.mysql.com/Downloads/MySQL-3.23/${A}"
+HOMEPAGE="http://www.mysql.com/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-apps/tcp-wrappers-7.6
+ =sys-libs/db-3.2.3h
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:DB_VERSION_STRING\.\*g:DB_VERSION_STRING.*h:" \
+ -e "s:-ldb:-ldb-3.2:" configure.orig > configure
+}
+
+src_compile() {
+ export CFLAGS="${CFLAGS/-O?/}"
+ export CXXFLAGS="${CXXFLAGS/-O?/}"
+ # Patch for qmail-mysql
+ cd ${S}/include
+ cp nisam.h nisam.h.orig
+ sed -e "s/define N_MAX_KEY_LENGTH 256/define N_MAX_KEY_LENGTH 500/" nisam.h.orig > nisam.h
+
+ cd ${S}
+ CXX=gcc ./configure --prefix=/usr --host=${CHOST} \
+ --enable-shared \
+ --enable-static \
+ --enable-assembler \
+ --enable-thread-safe-client \
+ --with-raid \
+ --with-low-memory \
+ --with-libwrap \
+ --without-readline \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/mysql \
+ --infodir=/usr/info \
+ --mandir=/usr/man \
+ --without-debug \
+ --with-mysql-user=mysql \
+ --with-berkeley-db-includes=/usr/include/db3 \
+ --with-berkeley-db-libs=/usr/lib
+ try make benchdir=/usr/share/mysql-bench
+}
+
+src_install() {
+
+ cd ${S}
+
+ # Install MySQL
+
+ try make install prefix=${D}/usr \
+ libdir=${D}/usr/lib \
+ libexecdir=${D}/usr/sbin \
+ sysconfdir=${D}/etc/mysql \
+ localstatedir=${D}/var/mysql \
+ infodir=${D}/usr/info \
+ mandir=${D}/usr/man \
+ benchdir=${D}/usr/share/mysql-bench
+
+
+ # Move Client Libs
+ mv ${D}/usr/lib/mysql/libmysqlclient.so* ${D}/usr/lib
+
+ insinto /usr/include/mysql
+ doins include/my_config.h include/my_dir.h
+ dodir /etc/mysql
+ cp scripts/mysqlaccess.conf ${D}/etc/mysql
+ cp ${O}/files/my.cnf ${D}/etc/mysql
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/mysql ${D}/etc/rc.d/init.d/mysql
+
+ # MySQL Docs
+
+ cd ${S}
+ into /usr
+ dodoc INSTALL-SOURCE README MIRRORS
+ cd ${S}/Docs
+ dodoc INSTALL-BINARY manual.ps manual.txt
+ docinto html
+ dodoc manual.html manual_toc.html
+
+}
+
+pkg_config () {
+
+ echo "Setting up symlinks..."
+ ${ROOT}/usr/sbin/rc-update add mysql
+
+}
+
+
+
+
+
+
+