summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-11-19 00:38:36 +0000
committerPeter Johanson <latexer@gentoo.org>2004-11-19 00:38:36 +0000
commitd9b927e6fc6a86107a61026214c56d2de7534e34 (patch)
tree4d7cc8345519301b44afd89ecd0dcf8fd84d8f2c /dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild
parentMove all current SLOT="0" gtk-sharp ebuilds -> SLOT="1" (diff)
downloadhistorical-d9b927e6fc6a86107a61026214c56d2de7534e34.tar.gz
historical-d9b927e6fc6a86107a61026214c56d2de7534e34.tar.bz2
historical-d9b927e6fc6a86107a61026214c56d2de7534e34.zip
Remove a bunch of older ebuilds, and move the slot of the current ebuilds from 0 -> 1
Diffstat (limited to 'dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild')
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild
deleted file mode 100644
index 793ddb7b5c1b..000000000000
--- a/dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-0.91.1.ebuild,v 1.1 2004/10/26 21:52:16 latexer Exp $
-
-inherit eutils mono
-
-DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://gtk-sharp.sourceforge.net/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="gnome gnomedb libgda gtkhtml"
-
-RDEPEND=">=sys-apps/sed-4.0
- >=dev-dotnet/mono-0.91
- >=x11-libs/gtk+-2.2
- >=gnome-base/libglade-2
- >=gnome-base/orbit-2.8.3
- gnome? ( >=gnome-base/libgnomecanvas-2.2
- >=gnome-base/libgnomeui-2.2
- >=gnome-base/libgnomeprintui-2.2 )
- libgda? ( >=gnome-extra/libgda-0.11 )
- gnomedb? ( >=gnome-extra/libgnomedb-0.11 )
- gtkhtml? ( >=gnome-extra/libgtkhtml-3.0.10 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-KEYWORDS="~x86 ~ppc"
-
-src_unpack() {
- unpack ${A}
-
- # Sets ${installvendorlib} variable to be used later
- eval `perl '-V:installvendorlib'`
-
- # disable building of samples (#16015)
- cd ${S}
- sed -i -e "s:sample::" -e "s:doc::" Makefile.in
-
- # Fix the installation location of the GAPI Metadata perl module
- cd ${S}/parser/GAPI/
- sed -i -e "s:\$(datadir)/perl5:${D}/${installvendorlib}:" Makefile.in
-}
-
-src_compile() {
- econf || die "./configure failed"
-
- MAKEOPTS="-j1" MONO_PATH=${S} emake || die
-}
-
-src_install () {
- # one of the samples require gconf schemas, and it'll violate sandbox
- GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" einstall || die
-
- dodoc README* ChangeLog
-}