summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 06:03:21 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 06:03:21 +0000
commit6cfa30f586a0ee38b60d441a7653de9dedccc4b1 (patch)
treea1673334b868d6ab9091392ad003c1b02f780850 /dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild
parentAdd hexpat (diff)
downloadhistorical-6cfa30f586a0ee38b60d441a7653de9dedccc4b1.tar.gz
historical-6cfa30f586a0ee38b60d441a7653de9dedccc4b1.tar.bz2
historical-6cfa30f586a0ee38b60d441a7653de9dedccc4b1.zip
Bump citeproc-hs to 0.3.6
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild')
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild
new file mode 100644
index 000000000000..fd2fa40f16a4
--- /dev/null
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild,v 1.1 2012/11/25 06:03:14 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Citation Style Language implementation in Haskell"
+HOMEPAGE="http://gorgias.mine.nu/repos/citeproc-hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils hexpat +network"
+
+RDEPEND="dev-haskell/json:=[generic,profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.8:=[profile?]
+ <dev-haskell/pandoc-types-1.11:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/time:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ >=dev-lang/ghc-6.10.4:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ network? (
+ >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"