summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:33:10 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:33:10 +0000
commit25a3c087ab579f6d43727d24688b2dddd833c135 (patch)
treef95397b3dbba567f372152f040d9dd847c18a7b3 /dev-haskell/wash
parentNew version. (diff)
downloadhistorical-25a3c087ab579f6d43727d24688b2dddd833c135.tar.gz
historical-25a3c087ab579f6d43727d24688b2dddd833c135.tar.bz2
historical-25a3c087ab579f6d43727d24688b2dddd833c135.zip
New version. Fix quoting issues in older ebuilds.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/wash')
-rw-r--r--dev-haskell/wash/ChangeLog8
-rw-r--r--dev-haskell/wash/files/digest-wash-2.123
-rw-r--r--dev-haskell/wash/wash-2.0.6.ebuild8
-rw-r--r--dev-haskell/wash/wash-2.12.ebuild63
-rw-r--r--dev-haskell/wash/wash-2.3.1.ebuild8
-rw-r--r--dev-haskell/wash/wash-2.5.6.ebuild4
6 files changed, 83 insertions, 11 deletions
diff --git a/dev-haskell/wash/ChangeLog b/dev-haskell/wash/ChangeLog
index 2fde3b059147..d739fae903d2 100644
--- a/dev-haskell/wash/ChangeLog
+++ b/dev-haskell/wash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/wash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/ChangeLog,v 1.12 2007/10/31 13:11:16 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/ChangeLog,v 1.13 2007/12/13 17:33:09 dcoutts Exp $
+
+*wash-2.12 (13 Dec 2007)
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> wash-2.0.6.ebuild,
+ wash-2.3.1.ebuild, wash-2.5.6.ebuild, +wash-2.12.ebuild:
+ New version. Fix quoting issues in older ebuilds.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org> wash-2.0.6.ebuild,
wash-2.3.1.ebuild, wash-2.5.6.ebuild:
diff --git a/dev-haskell/wash/files/digest-wash-2.12 b/dev-haskell/wash/files/digest-wash-2.12
new file mode 100644
index 000000000000..6bcbeae46c80
--- /dev/null
+++ b/dev-haskell/wash/files/digest-wash-2.12
@@ -0,0 +1,3 @@
+MD5 f71afefa55771f4f4b1d21fd5bb3f43c WashNGo-2.12.tgz 337362
+RMD160 53f0221345ae1de502991f17159cf8ecda84a9f3 WashNGo-2.12.tgz 337362
+SHA256 3f3f9724cbab24cbc45816be12c503064020cc9ffd585069eb835e290c10ccb7 WashNGo-2.12.tgz 337362
diff --git a/dev-haskell/wash/wash-2.0.6.ebuild b/dev-haskell/wash/wash-2.0.6.ebuild
index 03e38fadd83b..442555083c87 100644
--- a/dev-haskell/wash/wash-2.0.6.ebuild
+++ b/dev-haskell/wash/wash-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.0.6.ebuild,v 1.3 2007/10/31 13:11:16 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.0.6.ebuild,v 1.4 2007/12/13 17:33:09 dcoutts Exp $
inherit ghc-package
@@ -31,7 +31,7 @@ src_compile() {
./configure \
--prefix="${D}usr" \
--host=${CHOST} \
- --libdir=${D}/$(ghc-libdir) \
+ --libdir="${D}/$(ghc-libdir)" \
${myopts} \
--enable-register-package="${S}/$(ghc-localpkgconf)" \
|| die "configure failed"
@@ -41,11 +41,11 @@ src_compile() {
src_install() {
ghc-setup-pkg
- make exec_prefix=${D}/usr install || die "make install failed"
+ make exec_prefix="${D}/usr" install || die "make install failed"
ghc-install-pkg
dodoc README
if use doc; then
- cp -r Examples ${D}/usr/share/doc/${PF}
+ cp -r Examples "${D}/usr/share/doc/${PF}"
cd doc
dohtml -r *
fi
diff --git a/dev-haskell/wash/wash-2.12.ebuild b/dev-haskell/wash/wash-2.12.ebuild
new file mode 100644
index 000000000000..aad1072cce05
--- /dev/null
+++ b/dev-haskell/wash/wash-2.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.12.ebuild,v 1.1 2007/12/13 17:33:09 dcoutts Exp $
+
+CABAL_FEATURES="profile haddock lib bin"
+inherit haskell-cabal check-reqs
+
+MY_PN="WashNGo"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WASH is a family of embedded domain specific languages for programming Web applications in Haskell."
+HOMEPAGE="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/"
+SRC_URI="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6
+ dev-haskell/regex-compat"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # There are a couple Wash modules which take forever to compile and
+ # cause ghc take loads of memory. We try and limit ghc's heap size
+ # but it still takes a lot.
+ einfo "Some Wash modules take a lot of RAM and a very long time to compile."
+ einfo "Please be patient."
+ # We need aproximately this much memory: (does *not* check swap)
+ case "${ARCH}" in
+ alpha|*64) CHECKREQS_MEMORY="600" ;;
+ *) CHECKREQS_MEMORY="300" ;;
+ esac
+ check_reqs
+}
+
+src_unpack() {
+ unpack "${A}"
+
+ cabal-mksetup
+ sed -i -e "/Extensions/aGhc-Options: -O +RTS -M${CHECKREQS_MEMORY}m -RTS" \
+ "${S}/WASH.cabal"
+ echo "Ghc-Options: -O +RTS -M${CHECKREQS_MEMORY}m -RTS" \
+ >> "${S}/WASH.cabal"
+
+ # Add in the extra split-base deps
+ if version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e '/Build-Depends:/a \
+ ,containers' \
+ "${S}/WASH.cabal"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc README
+ if use doc; then
+ dodoc Examples
+ fi
+}
diff --git a/dev-haskell/wash/wash-2.3.1.ebuild b/dev-haskell/wash/wash-2.3.1.ebuild
index 0092fbfc5c95..53464874502f 100644
--- a/dev-haskell/wash/wash-2.3.1.ebuild
+++ b/dev-haskell/wash/wash-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.3.1.ebuild,v 1.3 2007/10/31 13:11:16 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.3.1.ebuild,v 1.4 2007/12/13 17:33:09 dcoutts Exp $
inherit ghc-package
@@ -31,7 +31,7 @@ src_compile() {
./configure \
--prefix="${D}usr" \
--host=${CHOST} \
- --libdir=${D}/$(ghc-libdir) \
+ --libdir="${D}/$(ghc-libdir)" \
${myopts} \
--enable-register-package="${S}/$(ghc-localpkgconf)" \
|| die "configure failed"
@@ -41,11 +41,11 @@ src_compile() {
src_install() {
ghc-setup-pkg
- make exec_prefix=${D}/usr install || die "make install failed"
+ make exec_prefix="${D}/usr" install || die "make install failed"
ghc-install-pkg
dodoc README
if use doc; then
- cp -r Examples ${D}/usr/share/doc/${PF}
+ cp -r Examples "${D}/usr/share/doc/${PF}"
cd doc
dohtml -r *
fi
diff --git a/dev-haskell/wash/wash-2.5.6.ebuild b/dev-haskell/wash/wash-2.5.6.ebuild
index 01e2137666d6..5c7ea6cb418c 100644
--- a/dev-haskell/wash/wash-2.5.6.ebuild
+++ b/dev-haskell/wash/wash-2.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.5.6.ebuild,v 1.5 2007/10/31 13:11:16 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.5.6.ebuild,v 1.6 2007/12/13 17:33:09 dcoutts Exp $
inherit base eutils ghc-package check-reqs autotools
@@ -76,7 +76,7 @@ src_install() {
dodoc README
if use doc; then
- cp -r Examples ${D}/usr/share/doc/${PF}
+ cp -r Examples "${D}/usr/share/doc/${PF}"
cd doc
dohtml -r *
fi