summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-06-01 21:24:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-06-01 21:24:47 +0000
commit23029ed5ae6df56f6f8f128be3ef479b38929e95 (patch)
treeb9a9e56281c897346fe818e56c4bc15281b1fff4 /dev-haskell/yaml/yaml-0.8.11.ebuild
parentInitial commit: Unicode Support version of Text.Regex, using regex-tdfa. A de... (diff)
downloadhistorical-23029ed5ae6df56f6f8f128be3ef479b38929e95.tar.gz
historical-23029ed5ae6df56f6f8f128be3ef479b38929e95.tar.bz2
historical-23029ed5ae6df56f6f8f128be3ef479b38929e95.zip
Version bump.
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0x611FF3AA
Diffstat (limited to 'dev-haskell/yaml/yaml-0.8.11.ebuild')
-rw-r--r--dev-haskell/yaml/yaml-0.8.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/yaml/yaml-0.8.11.ebuild b/dev-haskell/yaml/yaml-0.8.11.ebuild
new file mode 100644
index 000000000000..4144bee3d559
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.8.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/yaml-0.8.11.ebuild,v 1.1 2015/06/01 21:24:46 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents"
+HOMEPAGE="http://github.com/snoyberg/yaml/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-exe unicode system-libyaml"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/conduit-1.1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.1:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ system-libyaml? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/aeson-qq
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit )
+ system-libyaml? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-exe no-exe) \
+ $(usex unicode "--flags=-no-unicode" "--flags=no-unicode") \
+ $(cabal_flag system-libyaml system-libyaml)
+}