summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-07-14 22:11:35 +0000
committerVlastimil Babka <caster@gentoo.org>2008-07-14 22:11:35 +0000
commit59109f8d9cf54eba24dce75516c6622c3049e66e (patch)
tree26f6ebd1cdf35e40b3d46025f9c17f299b984f0a /dev-java/ant-apache-bsf
parentCopy local USE flags from ant-tasks to ant for 1.7.1. (diff)
downloadhistorical-59109f8d9cf54eba24dce75516c6622c3049e66e.tar.gz
historical-59109f8d9cf54eba24dce75516c6622c3049e66e.tar.bz2
historical-59109f8d9cf54eba24dce75516c6622c3049e66e.zip
Version bump, bug #231776.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64
Diffstat (limited to 'dev-java/ant-apache-bsf')
-rw-r--r--dev-java/ant-apache-bsf/ChangeLog10
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-java/ant-apache-bsf/ChangeLog b/dev-java/ant-apache-bsf/ChangeLog
index 42f7c8b2c72a..c936a86e094c 100644
--- a/dev-java/ant-apache-bsf/ChangeLog
+++ b/dev-java/ant-apache-bsf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-apache-bsf
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.13 2007/06/01 19:50:15 caster Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ChangeLog,v 1.14 2008/07/14 22:06:45 caster Exp $
+
+*ant-apache-bsf-1.7.1 (14 Jul 2008)
+
+ 14 Jul 2008; Vlastimil Babka <caster@gentoo.org>
+ +ant-apache-bsf-1.7.1.ebuild:
+ Version bump, bug #231776.
01 Jun 2007; Vlastimil Babka <caster@gentoo.org>
ant-apache-bsf-1.7.0-r1.ebuild:
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
new file mode 100644
index 000000000000..9cb35b0acd97
--- /dev/null
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-apache-bsf/ant-apache-bsf-1.7.1.ebuild,v 1.1 2008/07/14 22:06:45 caster Exp $
+
+EAPI=1
+
+ANT_TASK_DEPNAME="bsf-2.3"
+
+inherit eutils ant-tasks
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# ant-nodeps contains <script> task which is needed for this
+# although it's not a build dep through import
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3"
+RDEPEND="${DEPEND}
+ ~dev-java/ant-nodeps-${PV}"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_install() {
+ ant-tasks_src_install
+ java-pkg_register-dependency ant-nodeps
+}
+
+built_with_use_warn() {
+ if ! built_with_use --missing false -o dev-java/bsf ${1}; then
+ elog "If you want to use ${2} in <script> tasks in build.xml files,"
+ elog "dev-java/bsf must be installed with \"${3-${1}}\" USE flag"
+ fi
+}
+
+pkg_postinst() {
+ built_with_use_warn python Python
+ built_with_use_warn javascript JavaScript
+ built_with_use_warn tcl TCL
+ elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
+ elog "ruby and beanshell. See its postinst elog messages for instructions."
+}