summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-04 19:08:44 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-04 19:08:44 +0000
commit7a3e8a7010f151ec7643e5b9693a694006927a2d (patch)
tree9d541a39ce6b159bad95e14cf0f8a6299717a6d5 /dev-java/blowfishj/blowfishj-2.14-r1.ebuild
parentStable on ppc64; bug #138759 (diff)
downloadhistorical-7a3e8a7010f151ec7643e5b9693a694006927a2d.tar.gz
historical-7a3e8a7010f151ec7643e5b9693a694006927a2d.tar.bz2
historical-7a3e8a7010f151ec7643e5b9693a694006927a2d.zip
Revision bump to support new Java system.
Package-Manager: portage-2.1.1_pre1
Diffstat (limited to 'dev-java/blowfishj/blowfishj-2.14-r1.ebuild')
-rw-r--r--dev-java/blowfishj/blowfishj-2.14-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/blowfishj/blowfishj-2.14-r1.ebuild b/dev-java/blowfishj/blowfishj-2.14-r1.ebuild
new file mode 100644
index 000000000000..21dad59dfb9d
--- /dev/null
+++ b/dev-java/blowfishj/blowfishj-2.14-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14-r1.ebuild,v 1.1 2006/07/04 19:05:45 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Blowfish implementation in Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+HOMEPAGE="http://blowfishj.sourceforge.net/index.html"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="doc test"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant
+ app-arch/unzip
+ test? ( dev-java/junit ) "
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile() {
+ eant jar $(use_doc) || die "failed to compile"
+}
+
+src_test() {
+ eant test || die "test failed"
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/docs/api/*
+}