summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-12 14:02:42 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-12 14:02:42 +0000
commit4c6dffc8a16ef4eedb04aa1493de5f2c045980f6 (patch)
treef26c7b435c5aae9667030556a4043648dc2b8b5f /dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild
parentVersion bump (diff)
downloadhistorical-4c6dffc8a16ef4eedb04aa1493de5f2c045980f6.tar.gz
historical-4c6dffc8a16ef4eedb04aa1493de5f2c045980f6.tar.bz2
historical-4c6dffc8a16ef4eedb04aa1493de5f2c045980f6.zip
Dependency/style fixes
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild')
-rw-r--r--dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild
index 30b2d260e24b..2dfb9ff8cbfa 100644
--- a/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild
+++ b/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild,v 1.10 2005/05/18 11:17:03 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-jaxp/gnu-jaxp-1.0_beta1-r1.ebuild,v 1.11 2005/07/12 14:02:42 axxo Exp $
inherit java-pkg eutils
DESCRIPTION="GNU JAXP, a free implementation of SAX parser API, DOM Level 2, Sun JAXP 1.1."
HOMEPAGE="http://www.gnu.org/software/classpathx/jaxp/"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/classpathx/${PN/-/}-${PV/_beta1/beta1}.zip"
-DEPEND="app-arch/unzip"
-RDEPEND=">=virtual/jdk-1.3"
+DEPEND=">=virtual/jdk-1.3
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.3"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc amd64 ppc64 sparc"
@@ -23,8 +24,8 @@ src_compile() {
make ${makeflags} || die "compile failed!"
}
-src_install () {
- java-pkg_dojar gnujaxp.jar || die "Unable to Install"
+src_install() {
+ java-pkg_dojar gnujaxp.jar
dodoc README
use doc && java-pkg_dohtml -r apidoc/*
}