summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-08-13 04:28:40 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-08-13 04:28:40 +0000
commitf333ea339d22a4a54e5ef55a8cdd9231a14d145c (patch)
tree8371500b1753680b13943b509a3b8a0047884a64 /dev-libs/atlas
parentfiles dir (diff)
downloadhistorical-f333ea339d22a4a54e5ef55a8cdd9231a14d145c.tar.gz
historical-f333ea339d22a4a54e5ef55a8cdd9231a14d145c.tar.bz2
historical-f333ea339d22a4a54e5ef55a8cdd9231a14d145c.zip
new version, contains fix for gcc-3.3, added metadata
Diffstat (limited to 'dev-libs/atlas')
-rw-r--r--dev-libs/atlas/ChangeLog9
-rw-r--r--dev-libs/atlas/Manifest11
-rw-r--r--dev-libs/atlas/atlas-3.4.2.ebuild79
-rw-r--r--dev-libs/atlas/files/digest-atlas-3.4.21
-rw-r--r--dev-libs/atlas/metadata.xml5
5 files changed, 100 insertions, 5 deletions
diff --git a/dev-libs/atlas/ChangeLog b/dev-libs/atlas/ChangeLog
index 6ed507971f06..589589fb23fa 100644
--- a/dev-libs/atlas/ChangeLog
+++ b/dev-libs/atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/atlas
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/ChangeLog,v 1.6 2003/03/13 08:30:12 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/ChangeLog,v 1.7 2003/08/13 04:28:38 george Exp $
+
+*atlas-3.4.2 (12 Aug 2003)
+
+ 12 Aug 2003; George Shapovalov <george@gentoo.org> atlas-3.4.2.ebuild :
+ new version (#26348), this one builds with gcc-3.3
+ thanks to giggles1 <bevdv@yahoo.com> for notification
+ Also added metadata.xml
*atlas-3.4.1 (12 Mar 2003)
diff --git a/dev-libs/atlas/Manifest b/dev-libs/atlas/Manifest
index 395034eef502..839c09a0d482 100644
--- a/dev-libs/atlas/Manifest
+++ b/dev-libs/atlas/Manifest
@@ -1,7 +1,10 @@
-MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1 60
-MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1-r1 60
-MD5 ab8ce0151b53d1da05325b0f7294da48 files/digest-atlas-3.4.1 64
MD5 fd959682a17d471557198d9cf54db10c atlas-3.2.1-r1.ebuild 1902
MD5 fa3324f6e76e486717f54d75c495ebe8 atlas-3.2.1.ebuild 1907
-MD5 7485be0d4f0550143281dc288908a2d2 ChangeLog 1036
+MD5 b16ad5206cc2b8556dc234acbd777a41 atlas-3.4.2.ebuild 1867
MD5 e3feaec5bfd0ce662a659fa2f5bc907c atlas-3.4.1.ebuild 1856
+MD5 2e814af09893f40622ba56e442b20c45 ChangeLog 1274
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1 60
+MD5 ab8ce0151b53d1da05325b0f7294da48 files/digest-atlas-3.4.1 64
+MD5 e4430c91578bb055dad2d25c1d880cfa files/digest-atlas-3.4.2 64
+MD5 99e22e655a340b245ed25e144a5f07af files/digest-atlas-3.2.1-r1 60
diff --git a/dev-libs/atlas/atlas-3.4.2.ebuild b/dev-libs/atlas/atlas-3.4.2.ebuild
new file mode 100644
index 000000000000..f91fbdfce24c
--- /dev/null
+++ b/dev-libs/atlas/atlas-3.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.4.2.ebuild,v 1.1 2003/08/13 04:28:38 george Exp $
+
+IUSE=""
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/math-atlas/${PN}${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/ATLAS
+
+src_compile() {
+ # create a file answer to be redirected to make
+ echo "023" > answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ # the architecture of the processor is determined from the CFLAGS
+ case $CFLAGS in
+ *athlon*)
+ echo "AMD Athlon Processor Identified"
+ echo 2 >> answer;;
+ *pentiumpro*)
+ echo "Pentium Pro Processor Identified"
+ echo 3 >> answer;;
+ *pentium2*)
+ echo "Pentium II Processor Identified"
+ echo 4 >> answer;;
+ *pentium3*)
+ echo "Pentium III Processor Identified"
+ echo 5 >> answer;;
+ *pentium4*)
+ echo "Pentium IV Processor Identified"
+ echo 6 >> answer;;
+ *)
+ echo "Unknown Processor"
+ echo 1 >> answer;;
+ esac
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+
+ make < answer || die
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+ make install arch=${ATLAS_ARCH} || die
+}
+
+src_install () {
+ # almost completely copied from the atlas-3.2.1-r1 ebuild
+ cd ${S}/lib/${ATLAS_ARCH}
+
+ insinto /usr/lib
+ dolib.a libatlas.a libcblas.a libf77blas.a liblapack.a
+
+ cd ${S}/include
+ insinto /usr/include
+ doins cblas.h clapack.h
+
+ cd ${S}
+
+ dodoc README INSTALL.txt
+ dodoc doc/*.txt
+ insinto /usr/share/doc/${PN}-${PV}
+ doins doc/*.ps
+ dodoc bin/${ATLAS_ARCH}/INSTALL_LOG/SUMMARY.LOG
+}
diff --git a/dev-libs/atlas/files/digest-atlas-3.4.2 b/dev-libs/atlas/files/digest-atlas-3.4.2
new file mode 100644
index 000000000000..73a4f857712c
--- /dev/null
+++ b/dev-libs/atlas/files/digest-atlas-3.4.2
@@ -0,0 +1 @@
+MD5 db586b509821e0441cfd3b142b11c8ce atlas3.4.2.tar.bz2 1588614
diff --git a/dev-libs/atlas/metadata.xml b/dev-libs/atlas/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/dev-libs/atlas/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>