summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2005-09-28 19:49:18 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2005-09-28 19:49:18 +0000
commit236e678bd26ac787f6cec313501afdbd22f48794 (patch)
tree237c628c54ad2aeb6881ec9a5585e782a7b78537 /dev-libs/dvutil/dvutil-0.13.17.ebuild
parentno need to installspell any more. (diff)
downloadhistorical-236e678bd26ac787f6cec313501afdbd22f48794.tar.gz
historical-236e678bd26ac787f6cec313501afdbd22f48794.tar.bz2
historical-236e678bd26ac787f6cec313501afdbd22f48794.zip
Version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-libs/dvutil/dvutil-0.13.17.ebuild')
-rw-r--r--dev-libs/dvutil/dvutil-0.13.17.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/dvutil/dvutil-0.13.17.ebuild b/dev-libs/dvutil/dvutil-0.13.17.ebuild
new file mode 100644
index 000000000000..51aa3970f0c3
--- /dev/null
+++ b/dev-libs/dvutil/dvutil-0.13.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvutil/dvutil-0.13.17.ebuild,v 1.1 2005/09/28 19:49:18 pvdabeel Exp $
+
+inherit eutils
+
+DESCRIPTION="dvutil provides some general C++ utility classes for files, directories, dates, property lists, reference counted pointers, number conversion etc. "
+HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvutil/html/"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvutil/download/dvutil-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix-underquoted-m4.diff
+
+ sed -i 's|^\(SUBDIRS =.*\)doc\(.*\)$|\1\2|' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc ; then
+ doman doc/man/*/*.[1-9]
+ dohtml -r doc/html/*
+ fi
+}