summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-08 15:28:34 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-08 15:28:34 +0000
commit2eed5da0371fb1b562f84a88c8fc8e66aedf7217 (patch)
treed705110b8d936adc1120e66ddcb88f1eef1fd1b9 /dev-libs/glib/files
parentversion bump (diff)
downloadhistorical-2eed5da0371fb1b562f84a88c8fc8e66aedf7217.tar.gz
historical-2eed5da0371fb1b562f84a88c8fc8e66aedf7217.tar.bz2
historical-2eed5da0371fb1b562f84a88c8fc8e66aedf7217.zip
Don't check for python, and don't install gdb python scripts, bug 291328. Also, fix test failure in assert-msg-test, bug 323667
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'dev-libs/glib/files')
-rw-r--r--dev-libs/glib/files/glib-2.24-assert-test-failure.patch19
-rw-r--r--dev-libs/glib/files/glib-2.24-punt-python-check.patch20
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/glib/files/glib-2.24-assert-test-failure.patch b/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
new file mode 100644
index 000000000000..6d8e74f32500
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.24-assert-test-failure.patch
@@ -0,0 +1,19 @@
+Tests fail when upgrading glib from 2.22 to 2.24 if sys-devel/gdb is installed
+because gdb is run on .libs/assert-msg-test before LD_LIBRARY_PATH is set. This
+causes gdb to use the system-wide glib instead, and fail on the test.
+
+This patch exports LD_LIBRARY_PATH before running gdb
+
+https://bugzilla.gnome.org/621368
+
+---
+--- tests/run-assert-msg-test.sh
++++ tests/run-assert-msg-test.sh
+@@ -34,6 +34,7 @@ if [ -e ".libs/lt-$msg_test" ]; then
+ msg_test="lt-$msg_test"
+ fi
+ echo_v "Running gdb on assert-msg-test"
++export LD_LIBRARY_PATH="`dirname $PWD`/glib/.libs:$LD_LIBRARY_PATH"
+ OUT=$(gdb --batch --ex run --ex "print (char*) __glib_assert_msg" .libs/$msg_test 2> $error_out) || \
+ fail "failed to run gdb"
+
diff --git a/dev-libs/glib/files/glib-2.24-punt-python-check.patch b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
new file mode 100644
index 000000000000..3cbd6dc15155
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
@@ -0,0 +1,20 @@
+Remove python detection from configure.in, we won't be installing the gdb python
+scripts anymore. They use a redhat-specific gdb module that has not been
+upstreamed yet.
+
+https://bugs.gentoo.org/291328
+https://bugzilla.gnome.org/623552
+---
+--- configure.in
++++ configure.in
+@@ -379,10 +379,6 @@ if test "x$PERL_PATH" = x ; then
+ fi
+ AC_SUBST(PERL_PATH)
+
+-# Need suitable python path for greport
+-AM_PATH_PYTHON(2.4,,PYTHON="/usr/bin/env python2.4")
+-
+-
+ dnl ***********************
+ dnl *** Tests for iconv ***
+ dnl ***********************