summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-17 10:17:47 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-17 10:17:47 +0000
commit853188f90682d477fdaa06bdefaf714776dc900e (patch)
tree818608f09b9676aca7a58154c6665fe186a03ba7 /dev-libs/guiloader/guiloader-2.15.0.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-853188f90682d477fdaa06bdefaf714776dc900e.tar.gz
historical-853188f90682d477fdaa06bdefaf714776dc900e.tar.bz2
historical-853188f90682d477fdaa06bdefaf714776dc900e.zip
Version bump. Dropped old.
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'dev-libs/guiloader/guiloader-2.15.0.ebuild')
-rw-r--r--dev-libs/guiloader/guiloader-2.15.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/guiloader/guiloader-2.15.0.ebuild b/dev-libs/guiloader/guiloader-2.15.0.ebuild
new file mode 100644
index 000000000000..8386bb7b8aca
--- /dev/null
+++ b/dev-libs/guiloader/guiloader-2.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/guiloader/guiloader-2.15.0.ebuild,v 1.1 2009/06/17 10:16:11 pva Exp $
+
+DESCRIPTION="library to create GTK+ interfaces from GuiXml at runtime"
+HOMEPAGE="http://crow-designer.sourceforge.net"
+SRC_URI="mirror://sourceforge/crow-designer/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.14.0
+ >=dev-libs/glib-2.18.0"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.{ru,en}.txt,readme.{ru,en}.txt} || die
+}