summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-08-24 19:12:36 +0000
committerPeter Volkov <pva@gentoo.org>2006-08-24 19:12:36 +0000
commitb1118ade665d11e866bc53d675cff3e4a5c39b3d (patch)
tree4eccdf878f1e4dbdd4ac85f909bed0abe7e2aafb /dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
parentStable x86. (diff)
downloadhistorical-b1118ade665d11e866bc53d675cff3e4a5c39b3d.tar.gz
historical-b1118ade665d11e866bc53d675cff3e4a5c39b3d.tar.bz2
historical-b1118ade665d11e866bc53d675cff3e4a5c39b3d.zip
Misc ebuild/build process cleanups. Added ~amd64.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild')
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
new file mode 100644
index 000000000000..c35cbb839945
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnsres/libdnsres-0.1a-r1.ebuild,v 1.1 2006/08/24 19:12:36 pva Exp $
+
+DESCRIPTION="a non-blocking DNS resolver library"
+HOMEPAGE="http://www.monkey.org/~provos/libdnsres/"
+SRC_URI="http://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="|| ( as-is BSD )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libevent"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:LIBOBJS:LTLIBOBJS:" \
+ -e "s:CFLAGS:AM_CFLAGS:" Makefile.am || die "sed of Makefile.am failed"
+ # See Makefile.in for automake version upstream dev uses.
+ export WANT_AUTOMAKE=1.8
+ automake || die "automake failed"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}