summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-10-30 00:03:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-10-30 00:03:01 +0000
commit6b9553fdafdd2c52ebdc88e3bff5e13ac135fe90 (patch)
treecfeb8a38d5ddeb99fc6dd3522268700b0c2115ff /dev-libs/libindicate/files
parentInitial ebuild for GNOME 2.28. (diff)
downloadhistorical-6b9553fdafdd2c52ebdc88e3bff5e13ac135fe90.tar.gz
historical-6b9553fdafdd2c52ebdc88e3bff5e13ac135fe90.tar.bz2
historical-6b9553fdafdd2c52ebdc88e3bff5e13ac135fe90.zip
Update the gtk patch to exclude docs too.
Package-Manager: portage-2.2_rc46/cvs/Linux i686
Diffstat (limited to 'dev-libs/libindicate/files')
-rw-r--r--dev-libs/libindicate/files/libindicate-0.2.3-optional-gtk-support.patch39
1 files changed, 27 insertions, 12 deletions
diff --git a/dev-libs/libindicate/files/libindicate-0.2.3-optional-gtk-support.patch b/dev-libs/libindicate/files/libindicate-0.2.3-optional-gtk-support.patch
index 11288f7238e4..96512d691c61 100644
--- a/dev-libs/libindicate/files/libindicate-0.2.3-optional-gtk-support.patch
+++ b/dev-libs/libindicate/files/libindicate-0.2.3-optional-gtk-support.patch
@@ -1,17 +1,17 @@
From: Romain Perier <mrpouet@gentoo.org>
-Date: Thu, 29 Oct 2009 17:19:31 +0100
-Subject: Make gtk support optional and fix some QA: do not ever use ../something/something.la, it is prone to breakage (parallel build)
+Date: Thu, 29 Oct 2009 23:54:53 +0100
+Subject: Make gtk support optional, Fix some QA
---
- Makefile.am | 13 +++++---
- configure.ac | 17 ++++++++---
+ Makefile.am | 17 +++++++----
+ configure.ac | 23 ++++++++++++----
examples/Makefile.am | 62 ++++++++++++++++++++++--------------------
libindicate-gtk/Makefile.am | 2 +-
- 4 files changed, 53 insertions(+), 41 deletions(-)
+ 4 files changed, 61 insertions(+), 43 deletions(-)
--- a/Makefile.am
+++ b/Makefile.am
-@@ -1,9 +1,12 @@
+@@ -1,10 +1,15 @@
+SUBDIRS = libindicate
-SUBDIRS = \
@@ -19,16 +19,20 @@ Subject: Make gtk support optional and fix some QA: do not ever use ../something
- libindicate-gtk \
- examples \
- tests \
+- docs
+if HAVE_LIBINDICATEGTK
+SUBDIRS += libindicate-gtk
+endif
+
+SUBDIRS += \
+ examples \
-+ tests \
- docs
++ tests
++if INSTALL_DOC
++SUBDIRS += docs
++endif
EXTRA_DIST = \
+ COPYING.LGPL.2.1 \
--- a/configure.ac
+++ b/configure.ac
@@ -63,11 +63,18 @@ AC_SUBST(LIBINDICATE_LIBS)
@@ -54,7 +58,21 @@ Subject: Make gtk support optional and fix some QA: do not ever use ../something
+AM_CONDITIONAL([HAVE_LIBINDICATEGTK], [test "x$enable_gtk" != "xno"])
AC_SUBST(LIBINDICATEGTK_CFLAGS)
AC_SUBST(LIBINDICATEGTK_LIBS)
-
+
+@@ -103,8 +110,12 @@ AM_CONDITIONAL(USE_GIR, test "x$gir_ok" = "xyes")
+ # GTK Doc
+ ###########################
+
++AC_ARG_ENABLE([doc],
++ AC_HELP_STRING([--disable-doc], [Do not install API doc]),
++ [enable_doc=$enableval], [enable_doc=auto])
++AM_CONDITIONAL([INSTALL_DOC], [test "x$enable_doc" != "xno"])
+ GTK_DOC_CHECK([1.4])
+-GNOME_DOC_INIT
++#GNOME_DOC_INIT
+ GNOME_COMPILE_WARNINGS
+
+ ##############################
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -2,32 +2,11 @@
@@ -161,6 +179,3 @@ Subject: Make gtk support optional and fix some QA: do not ever use ../something
$(LIBINDICATEGTK_LIBS)
pkgconfig_DATA = indicate-gtk.pc
---
-1.6.5.1
-