summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:16:00 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:16:00 +0000
commit16f20f2719c5d6d606aadcc692df24062937caee (patch)
tree7ef83aba512362eb7036e3feacb7e7e059d1558d /dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
parentremove DEBUG=yes (diff)
downloadhistorical-16f20f2719c5d6d606aadcc692df24062937caee.tar.gz
historical-16f20f2719c5d6d606aadcc692df24062937caee.tar.bz2
historical-16f20f2719c5d6d606aadcc692df24062937caee.zip
cleanup old portage styles
Diffstat (limited to 'dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
index 460998b526f2..7124addf149f 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild
@@ -1,35 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.3 2003/07/23 21:20:01 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.7.ebuild,v 1.4 2003/08/03 02:16:00 vapier Exp $
inherit libtool
-S=${WORKDIR}/${P}
DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
-SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
HOMEPAGE="http://mcrypt.hellug.gr/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/${P}.tar.gz"
-DEPEND=">=sys-devel/automake-1.6.1
- >=sys-devel/libtool-1.4.1-r8"
-IUSE=""
-SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ~sparc ~ppc hppa ~alpha"
-src_compile() {
-
- local myconf
- myconf=""
- use pic && myconf="${myconf} --with-pic"
- econf ${myconf} || die "configure failure"
+DEPEND=">=sys-devel/automake-1.6.1
+ >=sys-devel/libtool-1.4.1-r8"
+src_compile() {
+ econf || die "configure failure"
emake || die "make failure"
}
-src_install () {
-
+src_install() {
dodir /usr/{bin,include,lib}
-
einstall || die "install failure"
dodoc AUTHORS KNOWN-BUGS COPYING COPYING.LIB INSTALL NEWS README THANKS TODO ChangeLog