summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-02-20 19:00:47 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-02-20 19:00:47 +0000
commit70308ecaa6d83d0999a233fcc30fe58abafe96ed (patch)
treeaae461cfd1ce37846a61cc99073f630888b40abe /dev-libs/libmowgli/libmowgli-9999.ebuild
parentadd missing test to IUSE (diff)
downloadhistorical-70308ecaa6d83d0999a233fcc30fe58abafe96ed.tar.gz
historical-70308ecaa6d83d0999a233fcc30fe58abafe96ed.tar.bz2
historical-70308ecaa6d83d0999a233fcc30fe58abafe96ed.zip
Add a live ebuild for libmowgli. This allows developers to use still slightly experimental stuff (like the VIO layer) and allows for the addition of an atheme-services live ebuild.
Package-Manager: portage-2.2.0_alpha87/cvs/Linux i686
Diffstat (limited to 'dev-libs/libmowgli/libmowgli-9999.ebuild')
-rw-r--r--dev-libs/libmowgli/libmowgli-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libmowgli/libmowgli-9999.ebuild b/dev-libs/libmowgli/libmowgli-9999.ebuild
new file mode 100644
index 000000000000..adafd9fb7e4e
--- /dev/null
+++ b/dev-libs/libmowgli/libmowgli-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmowgli/libmowgli-9999.ebuild,v 1.1 2012/02/20 19:00:47 jdhore Exp $
+
+EAPI=4
+
+inherit git-2
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
+HOMEPAGE="http://www.atheme.org/project/mowgli"
+EGIT_REPO_URI="git://git.atheme.org/libmowgli-2.git"
+IUSE="ssl"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS=""
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable ssl openssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README doc/BOOST
+}