summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-02-06 00:00:57 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-02-06 00:00:57 +0000
commitf14c92b5a336d7f4885f20d9814d1872edfdc8af (patch)
treeaca790832de7c299170655c6991fa27591b19d55 /dev-libs/libpcre/libpcre-7.6.ebuild
parentP.use.mask pam on sys-apps/openrc per UberLord's request (diff)
downloadhistorical-f14c92b5a336d7f4885f20d9814d1872edfdc8af.tar.gz
historical-f14c92b5a336d7f4885f20d9814d1872edfdc8af.tar.bz2
historical-f14c92b5a336d7f4885f20d9814d1872edfdc8af.zip
version bump, bug 208879, reported by Arfrever Frehtes Taifersar Arahesis <Arfrever DOT FTA AT GMail DOT Com>
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-libs/libpcre/libpcre-7.6.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-7.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libpcre/libpcre-7.6.ebuild b/dev-libs/libpcre/libpcre-7.6.ebuild
new file mode 100644
index 000000000000..12fb299f848f
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-7.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-7.6.ebuild,v 1.1 2008/02/06 00:00:57 opfer Exp $
+
+EAPI=1
+
+inherit libtool eutils
+
+MY_P="pcre-${PV}"
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 +cxx doc unicode zlib"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+}
+
+src_compile() {
+ # Enable building of static libs too - grep and others
+ # depend on them being built: bug 164099
+ econf --with-match-limit-recursion=8192 \
+ $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
+ $(use_enable cxx cpp) \
+ $(use_enable zlib pcregrep-libz) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ --enable-static \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+ emake all || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc doc/*.txt AUTHORS
+ use doc && dohtml doc/html/*
+}