summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-11 09:31:53 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-11 09:31:53 +0000
commit1cf9308e48d3fdbf047df7fc1fe97b553436939b (patch)
treea712b1957de872d9d8c1b880eacacc6181ecdb5d /dev-libs/openobex/openobex-1.7.1.ebuild
parentEAPI=5 (diff)
downloadhistorical-1cf9308e48d3fdbf047df7fc1fe97b553436939b.tar.gz
historical-1cf9308e48d3fdbf047df7fc1fe97b553436939b.tar.bz2
historical-1cf9308e48d3fdbf047df7fc1fe97b553436939b.zip
Version bump. Drop old patch.
Package-Manager: portage-2.2.12/cvs/Linux x86_64 Manifest-Sign-Key: 0xEFB4464E!
Diffstat (limited to 'dev-libs/openobex/openobex-1.7.1.ebuild')
-rw-r--r--dev-libs/openobex/openobex-1.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/openobex/openobex-1.7.1.ebuild b/dev-libs/openobex/openobex-1.7.1.ebuild
new file mode 100644
index 000000000000..5449c286fe1c
--- /dev/null
+++ b/dev-libs/openobex/openobex-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openobex/openobex-1.7.1.ebuild,v 1.1 2014/09/11 09:31:47 mgorny Exp $
+
+EAPI=5
+
+inherit cmake-utils udev
+
+DESCRIPTION="An implementation of the OBEX protocol used for transferring data to mobile devices"
+HOMEPAGE="http://sourceforge.net/projects/openobex/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-Source.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bluetooth irda usb"
+
+RDEPEND="bluetooth? ( net-wireless/bluez:= )
+ usb? ( virtual/libusb:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}-Source
+
+src_prepare() {
+ # Some of the bundled macros require C++... so making the project
+ # C only makes it impossible to build. CMake is awesome, isn't it?
+ sed -i -e '/project/s:C::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENOBEX_BLUETOOTH=$(usex bluetooth)
+ -DOPENOBEX_IRDA=$(usex irda)
+ -DOPENOBEX_USB=$(usex usb)
+ # TODO: enable them. patch would be appreciated.
+ -DBUILD_DOCUMENTATION=OFF
+
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)/rules.d"
+ )
+
+ cmake-utils_src_configure
+}