summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-09 14:54:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-09 14:54:17 +0000
commit5e9fdc5db91e0ef2ee6283272639a33f9da6f8cd (patch)
tree74283e922122d043bfa876db1cc0a563b308dfb0 /dev-libs/ustr/ustr-1.0.4-r3.ebuild
parentRevision bump adds upstream patch announced on packagers ml. Patch fixes clic... (diff)
downloadhistorical-5e9fdc5db91e0ef2ee6283272639a33f9da6f8cd.tar.gz
historical-5e9fdc5db91e0ef2ee6283272639a33f9da6f8cd.tar.bz2
historical-5e9fdc5db91e0ef2ee6283272639a33f9da6f8cd.zip
Fix installation path. Patch by Sven Eden <Yamakuzure@gmx.net> who will also be the maintainer
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xC2BA7F3C!
Diffstat (limited to 'dev-libs/ustr/ustr-1.0.4-r3.ebuild')
-rw-r--r--dev-libs/ustr/ustr-1.0.4-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/ustr/ustr-1.0.4-r3.ebuild b/dev-libs/ustr/ustr-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..3b2c861d3a5e
--- /dev/null
+++ b/dev-libs/ustr/ustr-1.0.4-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ustr/ustr-1.0.4-r3.ebuild,v 1.1 2013/11/09 14:54:14 hwoarang Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Low-overhead managed string library for C"
+HOMEPAGE="http://www.and.org/ustr"
+SRC_URI="ftp://ftp.and.org/pub/james/ustr/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD-2 MIT LGPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake AR=$(tc-getAR) CC=$(tc-getCC) CFLAGS="${CFLAGS}" HIDE= \
+ SHRDIR="/usr/share/${P}" \
+ all-shared
+}
+
+src_test() {
+ emake AR=$(tc-getAR) CC=$(tc-getCC) CFLAGS="${CFLAGS}" HIDE= check
+}
+
+src_install() {
+ emake install DESTDIR="${D}" HIDE= \
+ libdir="/usr/$(get_libdir)" \
+ mandir="/usr/share/man" \
+ SHRDIR="/usr/share/${P}" \
+ DOCSHRDIR="/usr/share/doc/${PF}"
+
+ dodoc ChangeLog README README-DEVELOPERS AUTHORS NEWS TODO
+}